archrelease: copy trunk to extra-x86_64
[arch-packages.git] / gnome-console / trunk / PKGBUILD
blob095c269e9062c01bdececedb42bba5cb09d56605
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Fabian Bornschein <fabiscafe-cat-mailbox-dog-org>
3 # Contributor: Igor Dyatlov <dyatlov.igor@gmail.com>
5 pkgname=gnome-console
6 pkgver=44.0
7 pkgrel=1
8 pkgdesc="A simple user-friendly terminal emulator for the GNOME desktop"
9 url="https://gitlab.gnome.org/GNOME/console"
10 arch=(x86_64)
11 license=(GPL3)
12 depends=(
13   libadwaita
14   libgtop
15   vte4
17 makedepends=(
18   appstream-glib
19   git
20   meson
22 groups=(gnome)
23 _commit=d3fd2f461a99e1f516d40077595021395f171310  # tags/44.0^0
24 source=("$pkgname::git+https://gitlab.gnome.org/GNOME/console.git#commit=$_commit")
25 b2sums=('SKIP')
27 pkgver() {
28   cd $pkgname
29   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
32 prepare() {
33   cd $pkgname
36 build() {
37   local meson_options=(
38     -D tests=true
39   )
41   arch-meson $pkgname build "${meson_options[@]}"
42   meson compile -C build
45 check() {
46   meson test -C build --print-errorlogs
49 package() {
50   meson install -C build --destdir "$pkgdir"
53 # vim:set sw=2 sts=-1 et: