archrelease: copy trunk to extra-x86_64
[arch-packages.git] / gnome-epub-thumbnailer / repos / extra-x86_64 / PKGBUILD
blob0cf22338b38ff6ab071dd9ff7e775ef21aa8605a
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=gnome-epub-thumbnailer
4 pkgver=1.7
5 pkgrel=1
6 pkgdesc="Thumbnailer for EPub and MOBI books"
7 url="https://gitlab.gnome.org/GNOME/gnome-epub-thumbnailer"
8 license=(GPL)
9 arch=(x86_64)
10 depends=(gdk-pixbuf2 librsvg libarchive libxml2)
11 makedepends=(git meson)
12 options=(debug)
13 _commit=24829a20630ee5a004f00b5fdd3b6830f593503f  # tags/1.7^0
14 source=("git+https://gitlab.gnome.org/GNOME/gnome-epub-thumbnailer.git#commit=$_commit")
15 sha256sums=('SKIP')
17 pkgver() {
18   cd $pkgname
19   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
22 prepare() {
23   cd $pkgname
26 build() {
27   arch-meson $pkgname build
28   meson compile -C build
31 check() {
32   meson test -C build --print-errorlogs
35 package() {
36   meson install -C build --destdir "$pkgdir"
40 # vim:set sw=2 sts=-1 et: