1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan De Groot <jgc@archlinux.org>
8 pkgdesc="Stores passwords and encryption keys"
9 url="https://wiki.gnome.org/Projects/GnomeKeyring"
12 depends=(gcr gcr-4 libcap-ng pam openssh)
13 makedepends=(git docbook-xsl python p11-kit)
14 provides=(org.freedesktop.secrets)
16 install=gnome-keyring.install
17 _commit=9d562e1e359e3ce01b61f0f52c75d38b96dece7b # tags/42.1^0
18 source=("git+https://gitlab.gnome.org/GNOME/gnome-keyring.git#commit=$_commit"
19 0001-build-Use-p11_module_configs-as-default-pkcs11-confi.patch
20 0002-daemon-Add-Cinnamon-to-autostart-files.patch)
22 '6985e3f7c60aa8dad794b1a9466f69737f3e9b5b7176e3888252c8c56647736a'
23 '91538221b304ef951a7d6d7441f8609a2787f725e55d60788b51e81f38c9012f')
27 git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
33 # Fix pkcs11 config dir
34 git apply -3 ../0001-build-Use-p11_module_configs-as-default-pkcs11-confi.patch
36 # Autolaunch in Cinnamon
37 git apply -3 ../0002-daemon-Add-Cinnamon-to-autostart-files.patch
39 NOCONFIGURE=1 ./autogen.sh
44 ./configure --prefix=/usr \
46 --localstatedir=/var \
47 --libexecdir=/usr/lib \
48 --with-pam-dir=/usr/lib/security \
50 --disable-schemas-compile
51 sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
57 # Secure memory tests fail
58 dbus-run-session make -k check || :
63 make DESTDIR="$pkgdir" install