archrelease: copy trunk to extra-x86_64
[arch-packages.git] / gnome-mahjongg / trunk / PKGBUILD
blobaf988acf298584cfac267b441d433b62095f0cae
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=gnome-mahjongg
5 pkgver=3.38.3
6 pkgrel=1
7 pkgdesc="Disassemble a pile of tiles by removing matching pairs"
8 url="https://wiki.gnome.org/Apps/Mahjongg"
9 arch=(x86_64)
10 license=(GPL)
11 depends=(gtk3 librsvg)
12 makedepends=(meson gobject-introspection yelp-tools appstream-glib git vala)
13 groups=(gnome-extra)
14 _commit=2214a09cdc2def8be5ae669a92aa31550e9f7cb4  # tags/3.38.3^0
15 source=("git+https://gitlab.gnome.org/GNOME/gnome-mahjongg.git#commit=$_commit")
16 sha256sums=('SKIP')
18 pkgver() {
19   cd $pkgname
20   git describe --tags | sed 's/-/+/g'
23 prepare() {
24   cd $pkgname
27 build() {
28   arch-meson $pkgname build \
29     -D compile-schemas=disabled \
30     -D update-icon-cache=disabled
31   meson compile -C build
34 check() {
35   meson test -C build --print-errorlogs
38 package() {
39   DESTDIR="$pkgdir" meson install -C build