archrelease: copy trunk to extra-x86_64
[arch-packages.git] / gnome-maps / repos / extra-x86_64 / PKGBUILD
blob1ebbac70a0e81ad3ef9d2b6cbf58d4bcae9b02a6
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=gnome-maps
5 pkgver=44.1
6 pkgrel=1
7 pkgdesc="A simple GNOME 3 maps application"
8 url="https://wiki.gnome.org/Apps/Maps"
9 arch=(x86_64)
10 license=(GPL)
11 depends=(
12   geoclue
13   geocode-glib-2
14   gjs
15   gtk4
16   libadwaita
17   libgweather-4
18   librest
19   libshumate
20   libxml2
22 makedepends=(
23   git
24   gobject-introspection
25   meson
26   yelp-tools
28 groups=(gnome)
29 _commit=20b36fbecf72db923dd5b1d7c8543c7989702137  # tags/v44.1^0
30 source=("git+https://gitlab.gnome.org/GNOME/gnome-maps.git#commit=$_commit")
31 b2sums=('SKIP')
33 pkgver() {
34   cd $pkgname
35   git describe --tags | sed 's/^v//;s/[^-]*-g/r&/;s/-/+/g'
38 prepare() {
39   cd $pkgname
42 build() {
43   arch-meson $pkgname build
44   meson compile -C build
47 check() {
48   meson test -C build --print-errorlogs
51 package() {
52   meson install -C build --destdir "$pkgdir"
55 # vim:set sw=2 sts=-1 et: