archrelease: copy trunk to extra-x86_64
[arch-packages.git] / gnome-menus / trunk / PKGBUILD
blob64afac207b8dd2a0dd41cf9620c4981a12a8a81d
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jan@archlinux.org>
4 pkgname=gnome-menus
5 pkgver=3.36.0
6 pkgrel=2
7 pkgdesc="GNOME menu specifications"
8 url="https://gitlab.gnome.org/GNOME/gnome-menus"
9 arch=(x86_64)
10 license=(GPL LGPL)
11 groups=(gnome)
12 depends=(glib2)
13 makedepends=(intltool gobject-introspection git gnome-common)
14 provides=(libgnome-menu-3.so)
15 _commit=66ac7579856968d3f4b76c04d55327c60b37f2fb  # tags/3.36.0^0
16 source=("git+https://gitlab.gnome.org/GNOME/gnome-menus.git#commit=$_commit")
17 sha256sums=('SKIP')
19 pkgver() {
20   cd $pkgname
21   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
24 prepare() {
25   cd $pkgname
26   NOCONFIGURE=1 ./autogen.sh
29 build() {
30   cd $pkgname
31   ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
32     --disable-static
33   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
34   make
37 check() {
38   cd $pkgname
39   make check
42 package(){
43   cd $pkgname
44   make DESTDIR="$pkgdir" install