archrelease: copy trunk to extra-x86_64
[arch-packages.git] / gnome-online-miners / trunk / PKGBUILD
blob73e30e64505324f0963ded74dc36950d88ce7166
1 # Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
4 pkgname=gnome-online-miners
5 pkgver=3.34.0
6 pkgrel=2
7 pkgdesc="Crawls through your online content"
8 arch=(x86_64)
9 url="https://wiki.gnome.org/Projects/GnomeOnlineMiners"
10 license=(GPL)
11 depends=(libgdata gnome-online-accounts grilo libzapojit tracker gfbgraph dleyna-server)
12 makedepends=(git autoconf-archive python)
13 _commit=f9aca437b511ca95e1ea6dab68c099aa9e9ae119  # tags/3.34.0^0
14 source=("git+https://gitlab.gnome.org/GNOME/gnome-online-miners.git#commit=$_commit")
15 sha256sums=('SKIP')
17 pkgver() {
18   cd $pkgname
19   git describe --tags | sed 's/-/+/g'
22 prepare() {
23   cd $pkgname
24   NOCONFIGURE=1 ./autogen.sh
26   
27 build() {
28   cd $pkgname
29   ./configure --prefix=/usr --libexecdir=/usr/lib --disable-static
30   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
31   make
34 package() {
35   cd $pkgname
36   make DESTDIR="$pkgdir" install
39 # vim:set ts=2 sw=2 et: