1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=gnome-settings-daemon
6 pkgdesc="GNOME Settings Daemon"
7 url="https://gitlab.gnome.org/GNOME/gnome-settings-daemon"
16 gsettings-desktop-schemas
43 optdepends=('usbguard: USB protection support')
45 backup=(etc/xdg/Xwayland-session.d/00-xrdb)
46 _commit=7cc9a78f1d562ea759d1776ed061d4339a6f4610 # tags/44.1^0
48 "git+https://gitlab.gnome.org/GNOME/gnome-settings-daemon.git#commit=$_commit"
49 "git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git"
56 git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
63 git submodule set-url subprojects/gvc "$srcdir/libgnome-volume-control"
64 git -c protocol.file.allow=always submodule update
68 arch-meson $pkgname build
69 meson compile -C build
73 meson test -C build --print-errorlogs
77 meson install -C build --destdir "$pkgdir"
80 # vim:set sw=2 sts=-1 et: