archrelease: copy trunk to extra-x86_64
[arch-packages.git] / gnome-sudoku / trunk / PKGBUILD
blobe027225bff773a127437414d9668d151a91bfeab
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=gnome-sudoku
5 pkgver=44.0
6 pkgrel=1
7 pkgdesc="Test your logic skills in this number grid puzzle"
8 url="https://wiki.gnome.org/Apps/Sudoku"
9 arch=(x86_64)
10 license=(GPL)
11 depends=(
12   gtk3
13   json-glib
14   libgee
15   qqwing
17 makedepends=(
18   git
19   meson
20   vala
21   yelp-tools
23 groups=(gnome-extra)
24 _commit=d3c0b46822aba8b512dc389e321648d6833a2c9c  # tags/44.0^0
25 source=("git+https://gitlab.gnome.org/GNOME/gnome-sudoku.git#commit=$_commit")
26 b2sums=('SKIP')
28 pkgver() {
29   cd $pkgname
30   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
33 prepare() {
34   cd $pkgname
37 build() {
38   arch-meson $pkgname build
39   meson compile -C build
42 check() {
43   meson test -C build --print-errorlogs
46 package() {
47   meson install -C build --destdir "$pkgdir"
50 # vim:set sw=2 sts=-1 et: