1 # Maintainer: Gaetan Bisson <bisson@archlinux.org>
2 # Contributor: kevin <kevin@archlinux.org>
3 # Contributor: John Proctor <jproctor@prium.net>
8 pkgdesc='Graph visualization software'
9 url='https://www.graphviz.org/'
12 depends=('libltdl' 'gd' 'librsvg' 'ghostscript' 'pango' 'gts' 'gsfonts')
13 makedepends=('swig' 'mono' 'guile' 'lua' 'perl' 'python' 'r' 'tk' 'qt6-base' 'gtk2')
14 optdepends=('mono: sharp bindings'
15 'guile: guile bindings'
18 'python: python bindings'
22 'gtk2: gtk output plugin'
24 source=("https://gitlab.com/graphviz/graphviz/-/archive/$pkgver/$pkgname-$pkgver.tar.gz"
25 'ghostscript918.patch')
26 sha256sums=('dd06f45f5bbcb1c7cbc67adab5359da2cd4b40533dc7c7424b3fc0e998bbd6c9'
27 '0083d126e27f2223ec4226fc1d71c9c84106968a0fdf65de838aee1e4882bfdb')
31 cd "${srcdir}/${pkgname}-${pkgver}"
32 patch -p1 -i ../ghostscript918.patch
37 cd "${srcdir}/${pkgname}-${pkgver}"
39 export CXXFLAGS+=' -fPIC -fpermissive'
41 ./configure --prefix=/usr \
42 --enable-python3=yes --disable-python --enable-lefty
43 sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool # Fix overlinking
48 cd "${srcdir}/${pkgname}-${pkgver}"
49 make DESTDIR="${pkgdir}" install
51 # fix symlink to symlink that doesn't get picked up by makepkg's zipman
52 ln -s gv2gxl.1.gz "${pkgdir}"/usr/share/man/man1/dot2gxl.1.gz
53 rm "${pkgdir}"/usr/share/man/man1/dot2gxl.1
55 # Deduplicates TCL libraries
56 cd "${pkgdir}/usr/lib/tcl8.6"
58 ln -s ../graphviz/tcl graphviz