archrelease: copy trunk to extra-x86_64
[arch-packages.git] / gspell / trunk / PKGBUILD
blob23614a0e2451044d4bd15e5f533fb960cf637134
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=gspell
5 pkgver=1.12.1
6 pkgrel=1
7 pkgdesc="Spell-checking library for GTK applications"
8 url="https://gitlab.gnome.org/GNOME/gspell"
9 arch=(x86_64)
10 license=(LGPL)
11 depends=(
12   enchant
13   glib2
14   gtk3
15   icu
17 makedepends=(
18   autoconf-archive
19   git
20   gobject-introspection
21   gtk-doc
22   vala
24 _commit=d04dec63809b009c1ab12b2f80ceeeeab4709a48  # tags/1.12.1^0
25 source=("git+https://gitlab.gnome.org/GNOME/gspell.git#commit=$_commit")
26 b2sums=('SKIP')
28 pkgver() {
29   cd gspell
30   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
33 prepare() {
34   cd gspell
35   NOCONFIGURE=1 ./autogen.sh
38 build() {
39   local configure_options=(
40     --prefix=/usr
41     --sysconfdir=/etc
42     --localstatedir=/var
43     --enable-gtk-doc
44   )
46   cd gspell
47   ./configure "${configure_options[@]}"
48   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
49   make
52 package(){
53   depends+=(
54     libenchant-2.so
55     libgtk-3.so
56     libg{lib,object,io}-2.0.so
57     libicuuc.so
58     libpango-1.0.so
59   )
60   provides+=("libgspell-${pkgver%%.*}.so")
62   cd gspell
63   make DESTDIR="$pkgdir" install
66 # vim:set sw=2 sts=-1 et: