1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Thijs Vermeir <thijsvermeir@gmail.com>
3 # Contributor: Denis Zawada <deno@rootnode.net>
8 pkgdesc="Library to ease handling and implementation of UPnP A/V profiles"
9 url="https://wiki.gnome.org/Projects/GUPnP"
12 depends=(glib2 libxml2)
13 makedepends=(gobject-introspection gtk-doc vala meson git)
15 _commit=86f148ebb920a8113190fd3e6cae636c9fdd3ca7 # tags/gupnp-av-0.14.1^0
16 source=("git+https://gitlab.gnome.org/GNOME/gupnp-av.git#commit=$_commit")
21 git describe --tags | sed 's/^gupnp-av-//;s/[^-]*-g/r&/;s/-/+/g'
29 arch-meson gupnp-av build -D gtk_doc=true
30 meson compile -C build
34 meson test -C build --print-errorlogs
38 depends+=(libg{lib,object}-2.0.so)
39 provides+=(libgupnp-av-1.0.so)
41 meson install -C build --destdir "$pkgdir"
44 # vim:set sw=2 sts=-1 et: