1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: György Balló <ballogy@freestart.hu>
5 pkgname=(gupnp gupnp-docs)
9 pkgdesc="An object-oriented UPNP framework"
10 url="https://wiki.gnome.org/Projects/GUPnP"
13 depends=(glib2 gssdp libxml2)
14 makedepends=(gobject-introspection gi-docgen vala meson git)
16 _commit=adb51197a7e3120027a295b36beda4571e628758 # tags/gupnp-1.6.3^0
17 source=("git+https://gitlab.gnome.org/GNOME/gupnp.git#commit=$_commit")
22 git describe --tags | sed 's/^gupnp-//;s/[^-]*-g/r&/;s/-/+/g'
30 arch-meson gupnp build -D gtk_doc=true
31 meson compile -C build
35 meson test -C build --print-errorlogs
39 local p="$1" f d; shift
41 d="$srcdir/$p/${f#$pkgdir/}"
42 mkdir -p "$(dirname "$d")"
44 rmdir -p --ignore-fail-on-non-empty "$(dirname "$f")"
50 depends+=(libg{lib,object,io,module}-2.0.so libgssdp-1.6.so libsoup-3.0.so)
51 optdepends=('python: gupnp-binding-tool')
52 provides=(libgupnp-1.6.so)
54 meson install -C build --destdir "$pkgdir"
57 _pick docs usr/share/doc
60 package_gupnp-docs() {
61 pkgdesc+=" (documentation)"
66 # vim:set sw=2 sts=-1 et: