archrelease: copy trunk to extra-x86_64
[arch-packages.git] / gupnp / repos / extra-x86_64 / PKGBUILD
blob0408e8544e6508e595aa3311cb6f8b85f0b40da6
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: György Balló <ballogy@freestart.hu>
4 pkgbase=gupnp
5 pkgname=(gupnp gupnp-docs)
6 pkgver=1.6.3
7 pkgrel=1
8 epoch=1
9 pkgdesc="An object-oriented UPNP framework"
10 url="https://wiki.gnome.org/Projects/GUPnP"
11 arch=(x86_64)
12 license=(LGPL)
13 depends=(glib2 gssdp libxml2)
14 makedepends=(gobject-introspection gi-docgen vala meson git)
15 options=(debug)
16 _commit=adb51197a7e3120027a295b36beda4571e628758  # tags/gupnp-1.6.3^0
17 source=("git+https://gitlab.gnome.org/GNOME/gupnp.git#commit=$_commit")
18 sha256sums=('SKIP')
20 pkgver() {
21   cd gupnp
22   git describe --tags | sed 's/^gupnp-//;s/[^-]*-g/r&/;s/-/+/g'
25 prepare() {
26   cd gupnp
29 build() {
30   arch-meson gupnp build -D gtk_doc=true
31   meson compile -C build
34 check() {
35   meson test -C build --print-errorlogs
38 _pick() {
39   local p="$1" f d; shift
40   for f; do
41     d="$srcdir/$p/${f#$pkgdir/}"
42     mkdir -p "$(dirname "$d")"
43     mv "$f" "$d"
44     rmdir -p --ignore-fail-on-non-empty "$(dirname "$f")"
45   done
49 package_gupnp() {
50   depends+=(libg{lib,object,io,module}-2.0.so libgssdp-1.6.so libsoup-3.0.so)
51   optdepends=('python: gupnp-binding-tool')
52   provides=(libgupnp-1.6.so)
54   meson install -C build --destdir "$pkgdir"
56   cd "$pkgdir"
57   _pick docs usr/share/doc
60 package_gupnp-docs() {
61   pkgdesc+=" (documentation)"
62   depends=()
63   mv docs/* "$pkgdir"
66 # vim:set sw=2 sts=-1 et: