1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: György Balló <ballogy@freestart.hu>
5 pkgname=(gupnp gupnp-docs)
9 pkgdesc="An object-oriented UPNP framework"
10 url="https://wiki.gnome.org/Projects/GUPnP"
13 depends=(glib2 gssdp libxml2)
14 makedepends=(gobject-introspection gi-docgen vala meson git)
15 _commit=adb51197a7e3120027a295b36beda4571e628758 # tags/gupnp-1.6.3^0
16 source=("git+https://gitlab.gnome.org/GNOME/gupnp.git#commit=$_commit")
21 git describe --tags | sed 's/^gupnp-//;s/[^-]*-g/r&/;s/-/+/g'
29 arch-meson gupnp build -D gtk_doc=true
30 meson compile -C build
34 meson test -C build --print-errorlogs
38 local p="$1" f d; shift
40 d="$srcdir/$p/${f#$pkgdir/}"
41 mkdir -p "$(dirname "$d")"
43 rmdir -p --ignore-fail-on-non-empty "$(dirname "$f")"
49 depends+=(libg{lib,object,io,module}-2.0.so libgssdp-1.6.so libsoup-3.0.so)
50 optdepends=('python: gupnp-binding-tool')
51 provides=(libgupnp-1.6.so)
53 meson install -C build --destdir "$pkgdir"
56 _pick docs usr/share/doc
59 package_gupnp-docs() {
60 pkgdesc+=" (documentation)"
65 # vim:set sw=2 sts=-1 et: