archrelease: copy trunk to extra-x86_64
[arch-packages.git] / hitori / repos / extra-x86_64 / PKGBUILD
blob07f855ab7b227c7c7f75a67dc5b49c91bd90012b
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Balló György <ballogyor+arch at gmail dot com>
4 pkgname=hitori
5 pkgver=44.0
6 pkgrel=1
7 pkgdesc="GTK+ application to generate and let you play games of Hitori"
8 url="https://wiki.gnome.org/Apps/Hitori"
9 arch=(x86_64)
10 license=(GPL)
11 depends=(gtk3)
12 makedepends=(
13   appstream-glib
14   git
15   meson
16   yelp-tools
18 groups=(gnome-extra)
19 _commit=53db1397d6a711862023d7a3070e785235a98c87  # tags/44.0^0
20 source=("git+https://gitlab.gnome.org/GNOME/hitori.git#commit=$_commit")
21 sha256sums=('SKIP')
23 pkgver() {
24   cd hitori
25   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
28 prepare() {
29   cd hitori
32 build() {
33   arch-meson hitori build
34   meson compile -C build
37 check() {
38   meson test -C build --print-errorlogs
41 package() {
42   meson install -C build --destdir "$pkgdir"
45 # vim:set sw=2 sts=-1 et: