archrelease: copy trunk to extra-x86_64
[arch-packages.git] / hyphen-nl / trunk / PKGBUILD
blob45174ee43525e6edd9236ea84407a83b109b21cb
1 # Contributor: Jelle van der Waa <jelle vdwaa nl>
3 pkgname=hyphen-nl
4 pkgver=20050617
5 pkgrel=6
6 pkgdesc="Dutch hyphenation rules"
7 arch=('any')
8 url="https://wiki.services.openoffice.org/wiki/Dictionaries#Dutch_.28Netherlands.29"
9 license=('GPL2')
10 optdepends=('hyphen: offers hyphenation library functions')
11 source=("https://www.mirrorservice.org/sites/download.openoffice.org/contrib/dictionaries/hyph_nl_NL.zip")
12 sha256sums=('f48cb8a7ec86b94fe7383fd0c781c83b69c57b595cb10a6a69a5444f4f2368a7')
14 package() {
15   install -dm755 "${pkgdir}/usr/share/hyphen"
16   install -m644 hyph_nl_NL.dic "${pkgdir}/usr/share/hyphen/hyph_nl_NL.dic"
18   pushd "${pkgdir}/usr/share/hyphen/"
19   nl_NL_aliases="nl_AW nl_BE"
20   for lang in ${nl_NL_aliases}; do
21         ln -s hyph_nl_NL.dic hyph_${lang}.dic
22   done
24   popd
26   # the symlinks
27   install -dm755 "${pkgdir}/usr/share/myspell/dicts"
28   pushd "${pkgdir}/usr/share/myspell/dicts"
29     for file in "${pkgdir}"/usr/share/hyphen/*; do
30       ln -sv /usr/share/hyphen/$(basename ${file}) .
31     done
32   popd
34   # docs
35   install -dm755 "${pkgdir}/usr/share/doc/${pkgname}"
36   install -m644 README_hyph_nl_NL.txt "${pkgdir}/usr/share/doc/${pkgname}/README_hyph_nl_NL.txt"