1 # Maintainer: AndyRTR <andyrtr@archlinux.org>
4 pkgname=('hyphen' 'hyphen-en')
8 url="https://hunspell.sf.net"
9 license=('GPL2' 'LGPL2.1' 'MPL')
10 makedepends=('glibc' 'perl')
12 source=(https://downloads.sourceforge.net/hunspell/${pkgname}-${pkgver}.tar.gz)
13 sha1sums=('0556c392beb59433e577e3517575801212201df6')
14 sha256sums=('304636d4eccd81a14b6914d07b84c79ebb815288c76fe027b9ebff6ff24d5705')
18 ./configure --prefix=/usr --disable-static
23 pkgdesc="library for high quality hyphenation and justification"
24 depends=('glibc' 'perl')
27 make DESTDIR="$pkgdir/" install-libLTLIBRARIES
28 make DESTDIR="$pkgdir/" install-binSCRIPTS
29 make DESTDIR="$pkgdir/" install-includeHEADERS
32 install -D -m644 COPYING "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
36 pkgdesc="English hyphenation rules"
38 optdepends=('hyphen: offers hyphenation library functions')
41 make DESTDIR="$pkgdir/" install-hyphDATA
43 pushd ${pkgdir}/usr/share/hyphen/
44 en_US_aliases="en_AG en_AU en_BS en_BW en_BZ en_CA en_DK en_GB en_GH en_HK en_IE en_IN en_JM en_NA en_NZ en_PH en_SG en_TT en_ZA en_ZW"
45 for lang in $en_US_aliases; do
46 ln -s hyph_en_US.dic hyph_$lang.dic
51 install -dm755 ${pkgdir}/usr/share/myspell/dicts
52 pushd "$pkgdir"/usr/share/myspell/dicts
53 for file in "$pkgdir"/usr/share/hyphen/*; do
54 ln -sv /usr/share/hyphen/$(basename $file) .