1 # Maintainer : Guillaume ALAUX <guillaume@archlinux.org>
2 # Contributor: Jochem Kossen <j.kossen@home.nl>
3 # Contributor: rtfreedman <rob.til.freedman@googlemail.com>
8 pkgdesc='Library for reading, writing, and manipulating ID3v1 and ID3v2 tags'
11 url="http://id3lib.sourceforge.net/"
12 depends=('zlib' 'gcc-libs')
13 source=(https://downloads.sourceforge.net/sourceforge/${pkgname}/${pkgname}-${pkgver}.tar.gz
14 00-add-libz-to-compilation.patch
15 05-create-m4-directory.patch
16 10-fix-compilation-with-cpp-headers.patch
17 15-fix-headers-of-main-functions.patch
18 20-create-manpages.patch
20 40-deal-with-mkstemp.patch
21 50-remove-outdated-check.patch
22 60-add-c-wrapper-functions.patch
23 60-fix_make_check.patch
24 60-id3lib-missing-nullpointer-check.patch
26 61-fix_vbr_stack_smash.patch)
28 sha256sums=('2749cc3c0cd7280b299518b1ddf5a5bcfe2d1100614519b68702230e26c7d079'
29 'e884395cf0bd7b44a550fc8785d79c0992d749be1edc45b00d289cbbd179c6d5'
30 'c41ec6889b775119f71c25fa09bb5110bcf550a14e6aac80597479df453de5fb'
31 '5fb24595095596ff55d876fb3e5277000f04c4f7a3e07aff5c05e11639dc2165'
32 '042deb7c2df1afa0851622b6086e8eb4b007cc6cfcd70210852d5c25e39b08b1'
33 '97442e14a5147df36f35d6a396e2b3fb6e155060ec672d91a68bd1a742234b4e'
34 'a7cce4176df773677bfc6a527a0465d460fe60a269402af9bdfc9dd6104ea6a4'
35 'd7999cdb425ba8013dd11da7fb570e875d368e5b1236c2b094abee8446f04218'
36 'f908af7715fb164081d191c766b040cefa0a94f1414e98f60bc38b3e0b1aa309'
37 '1b06c5d2c36e6a1f2236c4603a934d8cd675414dcfd52b997cb584404c0bc77d'
38 '88aded7423f266d2fedb0eef9dbb272b53cc776ae98bd71dd5afb30b6ac48515'
39 '85f20c4d3467f48df1bcaa4150bae55e95270cabb542589f167a914b2f553d04'
40 'b31bfa7213325776f6784a684f082814d3affb050d36a7c41cf1b1df07228c5c'
41 '5a24d460c9dd1e643ac57b817ea9cec87f44c1d49381065f83879b2eea36adf7')
44 cd "${srcdir}/${pkgname}-${pkgver}"
46 patch -p1 -i ../00-add-libz-to-compilation.patch
47 patch -p1 -i ../05-create-m4-directory.patch
48 patch -p1 -i ../10-fix-compilation-with-cpp-headers.patch
49 patch -p1 -i ../15-fix-headers-of-main-functions.patch
50 patch -p1 -i ../20-create-manpages.patch
51 patch -p1 -i ../30-fix-utf16.patch
52 patch -p1 -i ../40-deal-with-mkstemp.patch
53 patch -p1 -i ../60-add-c-wrapper-functions.patch
54 patch -p1 -i ../60-fix_make_check.patch
55 patch -p1 -i ../60-id3lib-missing-nullpointer-check.patch
56 patch -p1 -i ../60-spelling.patch
57 patch -p1 -i ../61-fix_vbr_stack_smash.patch
58 patch -p1 -i ../50-remove-outdated-check.patch
63 automake --add-missing --copy
67 cd "${srcdir}/${pkgname}-${pkgver}"
68 ./configure --prefix=/usr
73 cd "${srcdir}/${pkgname}-${pkgver}"
78 cd "${srcdir}/${pkgname}-${pkgver}"
79 make DESTDIR="${pkgdir}" install
81 install -d "${pkgdir}"/usr/share/man/man1
82 cp doc/man/* "${pkgdir}"/usr/share/man/man1