1 # Contributor: Eric Belanger <eric@archlinux.org>
7 pkgdesc="An interactive spell-checking program for Unix"
9 url="https://www.cs.hmc.edu/~geoff/ispell.html"
11 depends=('ncurses' 'sh')
12 options=('!makeflags')
13 source=(https://www.cs.hmc.edu/~geoff/tars/$pkgname-$pkgver.tar.gz
14 cflags-from-environment.patch
16 sha256sums=('cf0c6dede3fd25fada4375d86acafe583cb96d8fe546de746a92ebb6df895602'
17 '280459d2cdb17846aab202d53089fd13469e6e59ae9e6da4a95b475597dd4603'
18 '359eca8bfb77db63785c4c304ecd3568b26cdf736946388e509933fc8a3f66bd')
21 cd ${pkgname}-${pkgver}
23 # needed for full RELRO (FS#68037)
24 patch -Np1 -i ../cflags-from-environment.patch
26 sed -i -e 's/#undef USG/#define USG/' \
27 -e 's|/usr/local|/usr|' \
28 -e 's|/lib|/lib/ispell|' local.h.linux
29 cp local.h.linux local.h
33 cd ${pkgname}-${pkgver}
38 cd ${pkgname}-${pkgver}
40 # creating directory structure
41 install -dm755 "${pkgdir}"/usr/{bin,lib/ispell,share/man/man{1,5}}
43 # Installing binary tools
44 for b in buildhash findaffix icombine ijoin ispell iwhich munchlist tryaffix; do
45 install -m755 $b "${pkgdir}"/usr/bin/
48 # Installing man pages
49 install -m644 ispell.1 "${pkgdir}"/usr/share/man/man1/ispell.1
50 install -m644 ispell.5 "${pkgdir}"/usr/share/man/man5/ispell.5
52 # Installing dictionnaries
53 install -m644 languages/american/americanmed.hash \
54 "${pkgdir}"/usr/lib/ispell/americanmed.hash
55 install -m644 languages/english/english.aff \
56 "${pkgdir}"/usr/lib/ispell/english.aff
57 ln -s americanmed.hash "${pkgdir}"/usr/lib/ispell/american.hash
58 ln -s americanmed.hash "${pkgdir}"/usr/lib/ispell/english.hash
61 install -Dm644 "${srcdir}"/license.txt \
62 "${pkgdir}"/usr/share/licenses/${pkgname}/license.txt