archrelease: copy trunk to extra-x86_64
[arch-packages.git] / jemalloc / trunk / PKGBUILD
blob52cf441ad577cf2241aec8a9ae0eae513674659f
1 # Maintainer:  BartÅ‚omiej Piotrowski <bpiotrowski@archlinux.org>
2 # Contributor: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
3 # Contributor: Kovivchak Evgen <oneonfire@gmail.com>
5 pkgname=jemalloc
6 epoch=1
7 pkgver=5.3.0
8 pkgrel=2
9 pkgdesc='General-purpose scalable concurrent malloc implementation'
10 arch=('x86_64')
11 license=('BSD')
12 url='http://www.canonware.com/jemalloc/'
13 depends=('glibc')
14 makedepends=('clang')
15 options=('!lto')
16 provides=('libjemalloc.so')
17 optdepends=('perl: for jeprof')
18 source=("https://github.com/jemalloc/jemalloc/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.bz2")
19 sha256sums=('2db82d1e7119df3e71b7640219b6dfe84789bc0537983c3b7ac4f7189aecfeaa')
21 build() {
22   cd $pkgname-$pkgver
24   # FS#71745: GCC-built jemalloc causes telegram-desktop to crash a lot. The reason is still not clear.
25   export CC=clang
26   export CXX=clang++
28   ./configure \
29     --enable-autogen \
30     --prefix=/usr
31   make
34 package() {
35   cd $pkgname-$pkgver
37   make DESTDIR="$pkgdir" install
39   install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
40   chmod 644 "$pkgdir/usr/lib/libjemalloc_pic.a"