archrelease: copy trunk to extra-x86_64
[arch-packages.git] / kapidox / trunk / PKGBUILD
blob7e3a5b432cdbc1ae986a654d6888678df5ceb4be
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 # Contributor: Andrea Scarpino <andrea@archlinux.org>
5 pkgname=kapidox
6 pkgver=5.106.0
7 pkgrel=1
8 pkgdesc='Frameworks API Documentation Tools'
9 arch=(any)
10 url='https://community.kde.org/Frameworks'
11 license=(LGPL)
12 depends=(python-jinja python-yaml)
13 makedepends=(python-build python-installer python-wheel python-setuptools qt5-base)
14 groups=(kf5)
15 source=(https://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz{,.sig})
16 sha256sums=('4e844171a2d850f6a8ed9165a2f12b742fd6ea41b9f91358c51fcda1af97cd32'
17             'SKIP')
18 validpgpkeys=(53E6B47B45CEA3E0D5B7457758D0EE648A48B3BB) # David Faure <faure@kde.org>
20 build() {
21   cd $pkgname-$pkgver
22   python -m build --wheel --no-isolation
25 package() {
26   cd $pkgname-$pkgver
27   python -m installer --destdir="$pkgdir" dist/*.whl