archrelease: copy trunk to extra-x86_64
[arch-packages.git] / kcachegrind / repos / extra-x86_64 / PKGBUILD
blob2541dee458940f46f18e9b819a19ff1e9221fe62
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 # Contributor: Andrea Scarpino <andrea@archlinux.org>
5 pkgbase=kcachegrind
6 pkgname=(kcachegrind kcachegrind-common qcachegrind)
7 pkgver=23.04.1
8 pkgrel=1
9 pkgdesc='Visualization of Performance Profiling Data'
10 url='https://apps.kde.org/kcachegrind/'
11 arch=(x86_64)
12 license=(GPL LGPL FDL)
13 makedepends=(extra-cmake-modules kdoctools qt5-tools kio)
14 source=(https://download.kde.org/stable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz{,.sig})
15 sha256sums=('91d4679fb19bf1bfa2a3beb23c3f629aba2f0871dff09af144511901a26274ea'
16             'SKIP')
17 validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7  # Albert Astals Cid <aacid@kde.org>
18               F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87  # Christoph Feck <cfeck@kde.org>
19               D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heiko.becker@kde.org>
21 build() {
22   cmake -B build -S $pkgname-$pkgver \
23     -DBUILD_TESTING=OFF
24   cmake --build build
27 package_kcachegrind() {
28   groups=(kde-applications kdesdk)
29   depends=(kio kcachegrind-common)
30   optdepends=('graphviz: for plotting support')
32   DESTDIR="$pkgdir" cmake --install build
33   rm -r "$pkgdir"/usr/{bin/*tree,share/{doc,icons,locale}}
36 package_kcachegrind-common() {
37   pkgdesc+=' (common files)'
38   depends=(hicolor-icon-theme)
39   optdepends=('php: for pprof2calltree' 'perl: for dprof2calltree, memprof2calltree and op2calltree')
41   DESTDIR="$pkgdir" cmake --install build
42   rm -r "$pkgdir"/usr/{bin/kcachegrind,share/{kcachegrind,applications,metainfo}} # provided by kcachegrind
44   # Fix python 2 path
45   sed -i 's|#!/usr/bin/env python|#!/usr/bin/env python2|' \
46     "$pkgdir"/usr/bin/hotshot2calltree
49 package_qcachegrind() {
50   pkgdesc+=' (pure Qt version)'
51   depends=(qt5-base kcachegrind-common)
52   optdepends=('graphviz: for plotting support')
54   install -Dm755 build/bin/qcachegrind -t "$pkgdir"/usr/bin/
55   install -Dm644 $pkgbase-$pkgver/qcachegrind/qcachegrind.desktop -t "$pkgdir"/usr/share/applications/