archrelease: copy trunk to extra-x86_64
[arch-packages.git] / kcalendarcore / trunk / PKGBUILD
blob558248308c8d0259be67817595fba30c5cd00ce5
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=kcalendarcore
4 pkgver=5.106.0
5 pkgrel=1
6 pkgdesc='The KDE calendar access library'
7 arch=(x86_64)
8 url='https://community.kde.org/Frameworks'
9 license=(LGPL)
10 depends=(libical qt5-base)
11 makedepends=(extra-cmake-modules doxygen qt5-tools qt5-doc)
12 groups=(kf5)
13 source=(https://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz{,.sig})
14 sha256sums=('f478dd78bc1c05ebbda6146f96f920fa5ea8ba62c5d8b902693bf1cfc2589605'
15             'SKIP')
16 validpgpkeys=(53E6B47B45CEA3E0D5B7457758D0EE648A48B3BB) # David Faure <faure@kde.org>
18 build() {
19   cmake -B build -S $pkgname-$pkgver \
20     -DBUILD_TESTING=OFF \
21     -DBUILD_QCH=ON
22   cmake --build build
25 package() {
26   DESTDIR="$pkgdir" cmake --install build