archrelease: copy trunk to extra-x86_64
[arch-packages.git] / kismet / trunk / PKGBUILD
blob70df62a95b0ca9bbafcf7aa5a96088fa646048e0
1 # Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
2 # Maintainer: Juergen Hoetzel <juergen@archlinux.org>
3 # Contributor: Angel Velasquez <angvp@archlinux.org>
4 # Contributor: Jason Chu <jason@archlinux.org>
6 pkgname=kismet
7 pkgver=2022_08_R1
8 _realver="${pkgver//_/-}"
9 pkgrel=2
10 pkgdesc="802.11 layer2 wireless network detector, sniffer, and intrusion detection system"
11 url="https://www.kismetwireless.net/"
12 arch=('x86_64')
13 license=('GPL')
14 depends=('libpcap' 'pcre' 'bluez-libs' 'libcap' 'protobuf-c' 'libprotobuf-c.so'
15          'sqlite' 'libnm' 'gcc-libs' 'libusb' 'libusb-1.0.so' 'libnl' 'glibc' 'zlib' 'libelf'
16          'lm_sensors' 'systemd' 'python' 'python-setuptools' 'python-protobuf' 'python-pyserial'
17          'python-numpy' 'python-websockets' 'libwebsockets' 'libcap-ng'
18          libpcap.so libprotobuf.so libnm.so libwebsockets.so libsensors.so)
19 makedepends=('python-setuptools')
20 optdepends=(
21   'gpsd: log coordinates of detected networks'
22   'wireshark-cli: provide OUI files used to determine device manufacturer'
23   'wireshark-cli: mergecap, to merge multiple capture files'
24   'sox: provide the default kismet sound playback binary'
25   'festival: text-to-speech support'
26   'flite:  alternative/lightweight text-to-speech support')
27 backup=(
28   etc/kismet/kismet.conf
29   etc/kismet/kismet_80211.conf
30   etc/kismet/kismet_alerts.conf
31   etc/kismet/kismet_filter.conf
32   etc/kismet/kismet_httpd.conf
33   etc/kismet/kismet_logging.conf
34   etc/kismet/kismet_memory.conf
35   etc/kismet/kismet_uav.conf)
36 install=kismet.install
37 source=(https://www.kismetwireless.net/code/${pkgname}-${_realver}.tar.xz
38         kismet.sysusers
39         python-install-flags.patch)
40 sha512sums=('befca2dcd7016d96a17e97babbd6d88195fa61750ed616d104d10a85828ec160672c33bd2a1eae554d375feb55ea45a040a3e53c4410a3ff8c9bfa4b5c8bcdb1'
41             '452b728c30c9932bdb91741af425267da87a66962ea9b736751948881f5477dee0bff8e2eeca2befdea2920da6d7d9e198bde69cef8c48bb49a0093a7f0ef897'
42             'c24bff8ecc0288c0584f60760a27b364bf7b013aad809e4050bb6ed703fc60f3ea93f7e897717a6924333ac6734b20b99166846dae4a9c5c303ae1de39f6692c')
43 validpgpkeys=('354689DF3C9DED803381A661D7B28822738BBDB1') # Michael Kershaw
45 prepare() {
46   cd ${pkgname}-${_realver}
47   patch -Np0 < ../python-install-flags.patch
48   autoreconf -fiv
51 build() {
52   cd ${pkgname}-${_realver}
53   ./configure \
54     --prefix=/usr \
55     --localstatedir=/var \
56     --sysconfdir=/etc/kismet \
57     --with-suidgroup=315
58   make all plugins
61 package() {
62   cd ${pkgname}-${_realver}
63   make DESTDIR="${pkgdir}" install
65   # Makepkg strip bug #43600
66   chmod u+w "${pkgdir}"/usr/bin/kismet*
67   chmod o-x "${pkgdir}"/usr/bin/kismet_cap*
68   chown 0:315 "${pkgdir}"/usr/bin/kismet_cap*
70   install -Dm 644 ../kismet.sysusers "${pkgdir}/usr/lib/sysusers.d/kismet.conf"
73 # vim: ts=2 sw=2 et: