archrelease: copy trunk to extra-x86_64
[arch-packages.git] / kpeople / repos / extra-x86_64 / PKGBUILD
blob331c98362b6bd7afb5377893232b35ef4994ec5e
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Maintainer: Antonio Rojas <arojas@archlinux.org>
4 pkgname=kpeople
5 pkgver=5.106.0
6 pkgrel=1
7 pkgdesc='A library that provides access to all contacts and the people who hold them'
8 arch=(x86_64)
9 url='https://community.kde.org/Frameworks'
10 license=(LGPL)
11 depends=(kcoreaddons ki18n kwidgetsaddons kitemviews)
12 makedepends=(extra-cmake-modules doxygen qt5-tools qt5-doc qt5-declarative)
13 optdepends=('qt5-declarative: QML bindings')
14 groups=(kf5)
15 source=(https://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz{,.sig})
16 sha256sums=('3e0e2046922133640dae2c68b30603bb670b84809b1ce9cd3dd477300f1d7b58'
17             'SKIP')
18 validpgpkeys=(53E6B47B45CEA3E0D5B7457758D0EE648A48B3BB) # David Faure <faure@kde.org>
20 build() { 
21   cmake -B build -S $pkgname-$pkgver \
22     -DBUILD_TESTING=OFF \
23     -DBUILD_QCH=ON
24   cmake --build build
27 package() {
28   DESTDIR="$pkgdir" cmake --install build