archrelease: copy trunk to extra-x86_64
[arch-packages.git] / kpmcore / trunk / PKGBUILD
blob82cb7209c9c4a035e0222debcbe4b7b375e44849
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=kpmcore
4 pkgver=23.04.1
5 pkgrel=1
6 pkgdesc='Library for managing partitions'
7 arch=(x86_64)
8 url='https://apps.kde.org/partitionmanager/'
9 license=(GPL2)
10 depends=(smartmontools kcoreaddons kwidgetsaddons ki18n polkit-qt5 qca-qt5)
11 makedepends=(extra-cmake-modules)
12 optdepends=('e2fsprogs: ext2/3/4 support'
13             'xfsprogs: XFS support'
14             'jfsutils: JFS support'
15             'reiserfsprogs: Reiser support'
16             'ntfs-3g: NTFS support'
17             'dosfstools: FAT32 support'
18             'fatresize: FAT resize support'
19             'f2fs-tools: F2FS support'
20             'exfat-utils: exFAT support'
21             'exfatprogs: exFAT support (alternative to exfat-utils)'
22             'nilfs-utils: nilfs support'
23             'udftools: UDF support')
24 source=(https://download.kde.org/stable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz{,.sig})
25 sha256sums=('34522af0267062fa6a0ce3982e506aa067607cd3ecc9fd79164077753a03081f'
26             'SKIP')
27 validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7  # Albert Astals Cid <aacid@kde.org>
28               F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87  # Christoph Feck <cfeck@kde.org>
29               D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heiko.becker@kde.org>
31 build() {
32   cmake -B build -S $pkgname-$pkgver \
33     -DCMAKE_INSTALL_LIBEXECDIR=lib \
34     -DBUILD_TESTING=OFF
35   cmake --build build
38 package() {
39   DESTDIR="$pkgdir" cmake --install build