1 # Maintainer: Tobias Powalowski <tpowa@archlinux.org>
7 pkgdesc='Database of photographic lenses and a library that allows advanced access to the database'
9 url='https://lensfun.github.io/'
12 makedepends=(python libpng doxygen cmake)
13 optdepends=('python: for lensfun-update-data and lensfun-add-adapter')
14 source=(https://github.com/lensfun/lensfun/archive/v$pkgver/$pkgname-$pkgver.tar.gz)
15 sha256sums=('57ba5a0377f24948972339e18be946af12eda22b7c707eb0ddd26586370f6765')
18 cmake -B build -S $pkgname-$pkgver \
19 -DCMAKE_INSTALL_PREFIX=/usr \
20 -DCMAKE_CXX_FLAGS="$CXXFLAGS -fno-delete-null-pointer-checks"
25 DESTDIR="$pkgdir" cmake --install build