archrelease: copy trunk to extra-x86_64
[arch-packages.git] / lensfun / trunk / PKGBUILD
blobadc57a36de304fc912a66f1d1dff30a55dda895a
1 # Maintainer: Tobias Powalowski <tpowa@archlinux.org>
3 pkgname=lensfun
4 pkgver=0.3.3
5 pkgrel=2
6 epoch=1
7 pkgdesc='Database of photographic lenses and a library that allows advanced access to the database'
8 arch=(x86_64)
9 url='https://lensfun.github.io/'
10 license=(LGPL3)
11 depends=(glib2)
12 makedepends=(python libpng doxygen cmake)
13 optdepends=('python: for lensfun-update-data and lensfun-add-adapter')
14 source=(https://github.com/lensfun/lensfun/archive/v$pkgver/$pkgname-$pkgver.tar.gz)
15 sha256sums=('57ba5a0377f24948972339e18be946af12eda22b7c707eb0ddd26586370f6765')
17 build() {
18   cmake -B build -S $pkgname-$pkgver \
19     -DCMAKE_INSTALL_PREFIX=/usr \
20     -DCMAKE_CXX_FLAGS="$CXXFLAGS -fno-delete-null-pointer-checks"
21   cmake --build build  
24 package() {
25   DESTDIR="$pkgdir" cmake --install build