1 # Maintainer: Sébastien "Seblu" Luttringer <seblu@archlinux.org>
2 # Contributor: Allan McRae <allan@archlinux.org>
3 # Contributor: judd <jvinet@zeroflux.org>
9 pkgdesc='A terminal based program for viewing text files'
12 url='https://www.greenwoodsoftware.com/less/'
13 depends=('glibc' 'ncurses' 'pcre2')
14 validpgpkeys=('AE27252BD6846E7D6EAE1DD6F153A7C833235259') # Mark Nudelman
15 source=("https://www.greenwoodsoftware.com/$pkgname/$pkgname-$pkgver.tar.gz"
16 "$pkgname-$pkgver.tar.gz.sig::https://www.greenwoodsoftware.com/$pkgname/$pkgname-$pkgver.sig")
17 sha256sums=('2f201d64b828b88af36dfe6cfdba3e0819ece2e446ebe6224813209aaefed04f'
22 # apply patch from the source array (should be a pacman feature)
24 for src in "${source[@]}"; do
27 [[ $src = *.patch ]] || continue
28 echo "Applying patch $src..."
29 patch -Np1 < "../$src"
35 sh configure --prefix=/usr --sysconfdir=/etc --with-regex=pcre2
41 make DESTDIR="$pkgdir" install
44 # vim:set ts=2 sw=2 et: