archrelease: copy trunk to extra-x86_64
[arch-packages.git] / lftp / trunk / PKGBUILD
blob1969c602c343e7bd47b4a2014b39088241434141
1 # Maintainer: Andreas Radke <andyrtr@archlinux.org>
2 # Contributor: Aaron Griffin <aaron@archlinux.org>
4 pkgname=lftp
5 pkgver=4.9.2
6 pkgrel=1
7 pkgdesc="Sophisticated command line based FTP client"
8 arch=('x86_64')
9 license=('GPL3')
10 depends=('gcc-libs' 'readline' 'gnutls' 'expat' 'sh' 'hicolor-icon-theme')
11 optdepends=('perl: needed for convert-netscape-cookies and verify-file')
12 url="https://lftp.yar.ru/"
13 backup=('etc/lftp.conf')
14 source=(https://lftp.yar.ru/ftp/${pkgname}-${pkgver}.tar.xz{,.asc})
15 sha256sums=('c517c4f4f9c39bd415d7313088a2b1e313b2d386867fe40b7692b83a20f0670d'
16             'SKIP')
17 validpgpkeys=('C027FA3148652A5513036413A824BB69F2A99A18') # "Alexander V. Lukyanov <lav@yars.free.net>"
19 build() {
20   cd "${pkgname}"-${pkgver}
21   ./configure --prefix=/usr \
22     --with-gnutls \
23     --without-openssl \
24     --without-included-regex \
25     --disable-static
26   make
29 package() {
30   cd "${pkgname}"-${pkgver}
31   make DESTDIR="${pkgdir}" install
32   rm -rf "${pkgdir}"/usr/lib