archrelease: copy trunk to extra-x86_64
[arch-packages.git] / libaccounts-glib / repos / extra-x86_64 / PKGBUILD
blob1c6503336e769b45e89d1c9d2a5becd5d055ab5c
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Contributor: Andrea Scarpino <andrea@archlinux.org>
3 # Contributor: Balló György <ballogyor+arch at gmail dot com>
5 pkgname=libaccounts-glib
6 pkgver=1.26
7 pkgrel=2
8 pkgdesc='Glib-based client library for accessing the online accounts database'
9 arch=(x86_64)
10 url='https://gitlab.com/accounts-sso/libaccounts-glib'
11 license=(LGPL)
12 depends=(glib2 libxml2 sqlite)
13 makedepends=(python-gobject gobject-introspection vala meson check)
14 source=(https://gitlab.com/accounts-sso/libaccounts-glib/-/archive/VERSION_$pkgver/libaccounts-glib-VERSION_$pkgver.tar.gz)
15 sha256sums=('8bc05c4f4a9b0412a8a70b5ddd3b80e5f4fa2d38455a5ebe638599668a287393')
17 build() {
18   meson $pkgname-VERSION_$pkgver build \
19     -Dprefix=/usr
20   meson compile -C build
23 check() {
24   meson test -C build || true
27 package() {
28   meson install -C build --destdir "$pkgdir"