archrelease: copy trunk to extra-x86_64
[arch-packages.git] / libcerf / repos / extra-x86_64 / PKGBUILD
blob7c8de5811a607d8a6ee39193d3a20f17164b7269
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=libcerf
4 epoch=1
5 pkgver=2.3
6 pkgrel=2
7 pkgdesc='Self-contained numeric library that provides an efficient and accurate implementation of complex error functions'
8 arch=(x86_64)
9 url='https://jugit.fz-juelich.de/mlz/libcerf/'
10 license=(custom)
11 depends=(glibc)
12 makedepends=(cmake)
13 source=(https://jugit.fz-juelich.de/mlz/libcerf/-/archive/v$pkgver/libcerf-v$pkgver.tar.gz)
14 sha256sums=('cceefee46e84ce88d075103390b4f9d04c34e4bc3b96d733292c36836d4f7065')
16 build() {
17   cmake -B build -S $pkgname-v$pkgver \
18     -DCMAKE_INSTALL_PREFIX=/usr \
19     -DPORTABLE=ON
20   cmake --build build
23 package() {
24   DESTDIR="$pkgdir" cmake --install build
26   install -Dm644 $pkgname-v$pkgver/LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname