archrelease: copy trunk to extra-x86_64
[arch-packages.git] / libepubgen / repos / extra-x86_64 / PKGBUILD
blob15a61f6ab71eda528992903ce2fc6e9581ec276f
1 # Maintainer: AndyRTR <andyrtr@archlinux.org>
3 pkgname=libepubgen
4 pkgver=0.1.1
5 pkgrel=4
6 pkgdesc="an EPUB generator for librevenge"
7 arch=('x86_64')
8 url="https://sourceforge.net/projects/libepubgen/"
9 license=('MPL2')
10 depends=('librevenge')
11 makedepends=('boost' 'cppunit' 'doxygen' 'libxml2')
12 options=('debug')
13 source=("https://sourceforge.net/projects/$pkgname/files/$pkgname-$pkgver/$pkgname-$pkgver.tar.xz")
14 sha1sums=('48e81c60e173552fce77ce3b414e68b7d52a5301')
15 sha256sums=('03e084b994cbeffc8c3dd13303b2cb805f44d8f2c3b79f7690d7e3fc7f6215ad')
17 build() {
18         cd "$pkgname-$pkgver"
19         ./configure --prefix=/usr
20         make
23 check() {
24         cd "$pkgname-$pkgver"
25         make check
28 package() {
29         cd "$pkgname-$pkgver"
30         make DESTDIR="$pkgdir/" install