archrelease: copy trunk to extra-x86_64
[arch-packages.git] / libgee / trunk / PKGBUILD
blob3bb40c27d15d6de13b49b025c24d14b0a944b0dc
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
3 # Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
5 pkgname=libgee
6 pkgver=0.20.6
7 pkgrel=1
8 pkgdesc="A collection library providing GObject-based interfaces and classes for commonly used data structures"
9 url="https://gitlab.gnome.org/GNOME/libgee"
10 license=(LGPL2.1)
11 arch=(x86_64)
12 depends=(glib2)
13 makedepends=(gobject-introspection vala autoconf-archive git)
14 _commit=7d332f82c750ba72a6c625f38e4bfd44b786a926  # tags/0.20.6^0
15 source=("git+https://gitlab.gnome.org/GNOME/libgee.git#commit=$_commit")
16 sha256sums=('SKIP')
18 pkgver() {
19   cd libgee
20   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
23 prepare() {
24   cd libgee
25   NOCONFIGURE=1 ./autogen.sh
28 build() {
29   cd libgee
30   ./configure --prefix=/usr --disable-static
31   make
34 check() {
35   cd libgee
36   # generates a bazillion traps - make sure systemd's core_pattern
37   # is deactivated, or you'll DoS the journal and the system
38   #make check
41 package() {
42   depends+=(libg{lib,object,io}-2.0.so)
43   provides+=(libgee-0.8.so)
45   cd libgee
46   make DESTDIR="$pkgdir" install