1 # Maintainer: David Runge <dvzrv@archlinux.org>
2 # Maintainer: Lukas Fleischer <lfleischer@archlinux.org>
3 # Contributor: Hilton Medeiros <medeiros.hilton@gmail.com>
4 # Contributor: Dave Reisner <d@falconindy.com>
10 pkgdesc="A linkable library for Git"
12 url="https://github.com/libgit2/libgit2"
28 source=($url/archive/v$pkgver/$pkgname-v$pkgver.tar.gz)
29 sha512sums=('fd73df91710f19b0d6c3765c37c7f529233196da91cf4d58028a8d3840244f11df44abafabd74a8ed1cbe4826d1afd6ff9f01316d183ace0924c65e7cf0eb8d5')
30 b2sums=('103af9ea9ed1310b1066a48859bbefc162647d787519bb3df83d7ea1957cda5934537271970d3d180f91daa6edc3bbc05387d6293812f0d849dda966419d29ba')
35 -DCMAKE_BUILD_TYPE=None
36 -DCMAKE_INSTALL_PREFIX=/usr
38 -DUSE_HTTP_PARSER=system
44 cmake "${cmake_options[@]}"
45 cmake --build build --verbose
53 'network_url_parse__hostname_implied_root_empty_port|'
54 'network_url_parse__hostname_empty_port|'
55 'network_url_parse__ipv4_implied_root_empty_port|'
56 'network_url_parse__ipv4_empty_port|'
57 'network_url_parse__ipv6_implied_root_empty_port|'
58 'network_url_parse__ipv6_empty_port'
62 # NOTE: disable tests requiring the internet, relying on non-existent
63 # resources, or those that are only compatible with the (modified) vendored
64 # version of http-parser, but not with upstream http-parser
65 ctest --test-dir build --output-on-failure -E "${ignored_tests[*]}"
72 openssl libcrypto.so libssl.so
76 DESTDIR="$pkgdir" cmake --install build
77 install -vDm 644 $pkgname-$pkgver/{AUTHORS,README.md} -t "$pkgdir/usr/share/doc/$pkgname/"