1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=libgnome-games-support-2
6 pkgdesc="Code shared between GNOME games"
7 url="https://gitlab.gnome.org/GNOME/libgnome-games-support"
11 makedepends=(vala git meson)
12 provides=("libgnome-games-support-${pkgver%%.*}.so")
14 _commit=75ed95f923d77705d5cb5eea14625a655a3225c8 # tags/2.0.0^0
15 source=("git+https://gitlab.gnome.org/GNOME/libgnome-games-support.git#commit=$_commit")
19 cd libgnome-games-support
20 git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
24 cd libgnome-games-support
28 arch-meson libgnome-games-support build
29 meson compile -C build
33 meson test -C build --print-errorlogs
37 meson install -C build --destdir "$pkgdir"