1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
3 # Contributor: Sarah Hay <sarahhay@mb.sympatico.ca>
9 pkgdesc="An extensible I/O abstraction library for dealing with structured file formats"
10 url="https://gitlab.gnome.org/GNOME/libgsf"
12 depends=(libxml2 gdk-pixbuf2 bzip2)
13 makedepends=(gobject-introspection git gtk-doc autoconf-archive)
14 checkdepends=(perl-xml-parser unzip valgrind)
15 provides=(libgsf-1.so)
16 _commit=3f6b8dc6f2ba395eeb0dc3c2ebc60c14105be3e1 # tags/LIBGSF_1_14_50^0
17 source=("git+https://gitlab.gnome.org/GNOME/libgsf.git#commit=$_commit")
22 git describe --tags | sed 's/^LIBGSF_//;s/_/./g;s/[^-]*-g/r&/;s/-/+/g'
27 NOCONFIGURE=1 ./autogen.sh
31 local configure_options=(
36 --enable-introspection
41 ./configure "${configure_options[@]}"
42 sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
53 make DESTDIR="$pkgdir" install
56 # vim:set sw=2 sts=-1 et: