1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
5 pkgname=(libgweather-4 libgweather-4-docs)
8 pkgdesc="Location and timezone database and weather-lookup library"
9 url="https://wiki.gnome.org/Projects/LibGWeather"
12 depends=(libsoup3 geocode-glib-2 dconf libxml2)
13 makedepends=(gobject-introspection vala git gi-docgen meson python-gobject)
14 checkdepends=(python-pylint)
16 _commit=699cfb7e114acba4e066ebda9a51e6820da3daa7 # tags/4.2.0^0
17 source=("git+https://gitlab.gnome.org/GNOME/libgweather.git#commit=$_commit"
18 disable-metar-test.diff)
20 '42ebd95b2de37ff959a759546473985a86fa1a5488211b303a97540f2b7a8805')
24 git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
30 # Disable metar test, depends on unstable online service
31 git apply -3 ../disable-metar-test.diff
35 arch-meson libgweather build -D gtk_doc=true
36 meson compile -C build
40 meson test -C build --print-errorlogs
43 package_libgweather-4() {
44 provides=(libgweather-4.so)
46 meson install -C build --destdir "$pkgdir"
48 mkdir -p doc/usr/share
49 mv {"$pkgdir",doc}/usr/share/doc
52 package_libgweather-4-docs() {
53 pkgdesc+=" (documentation)"