archrelease: copy trunk to extra-x86_64
[arch-packages.git] / libheif / trunk / PKGBUILD
blob0de0a0d62030a2a1ef04887fd0659b6cc204ae9a
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Contributor: Adam Fontenot <fontenot@ucla.edu>
4 pkgname=libheif
5 pkgver=1.16.1
6 pkgrel=2
7 pkgdesc='HEIF file format decoder and encoder'
8 arch=(x86_64)
9 url='https://github.com/strukturag/libheif'
10 license=(GPL3)
11 makedepends=(cmake libjpeg libpng gdk-pixbuf2 svt-av1 rav1e)
12 depends=(libde265 x265 aom dav1d)
13 optdepends=('libjpeg: for heif-convert and heif-enc' 'libpng: for heif-convert and heif-enc'
14             'svt-av1: svt-av1 encoder' 'rav1e: rav1e encoder')
15 source=(https://github.com/strukturag/libheif/releases/download/v$pkgver/libheif-$pkgver.tar.gz)
16 sha256sums=('ac15b54b6d7c315710e156d119b8a1bfc89f29621e99222b2750b1f31c9c3558')
18 build() {
19   cmake -B build -S $pkgname-$pkgver\
20     -DCMAKE_INSTALL_PREFIX=/usr \
21     -DAOM_ENCODER=ON
22   cmake --build build
25 package() {
26   DESTDIR="$pkgdir" cmake --install build