archrelease: copy trunk to extra-x86_64
[arch-packages.git] / libiscsi / trunk / PKGBUILD
blob08f6bf8c8c23ec9d68d7a01e915f04b857b06e80
1 # Maintainer: Tobias Powalowski <tpowa@archlinux.org>
2 # Contributor: Patryk Kowalczyk <patryk@kowalczyk.ws>
3 pkgname=libiscsi
4 pkgver=1.19.0
5 pkgrel=2
6 makedepends=('git')
7 depends=('glibc' 'popt' 'libgcrypt')
8 pkgdesc="Clientside library to implement the iSCSI protocol"
9 arch=(x86_64)
10 url="https://github.com/sahlberg/libiscsi"
11 license=('LGPL')
12 source=(libiscsi::git+https://github.com/sahlberg/libiscsi.git#tag=${pkgver})
13 sha512sums=('SKIP')
15 build() {
16   cd "${srcdir}/${pkgname}"
17   ./autogen.sh
19   # Disabled werror due to GCC 8 warnings: https://github.com/sahlberg/libiscsi/issues/266
20   ./configure --prefix=/usr --disable-static --libdir=/usr/lib --disable-werror 
21   make
24 check() {
25   cd "${srcdir}/${pkgname}"
26   make check
29 package () {
30   cd "${srcdir}/${pkgname}"
31   make DESTDIR="${pkgdir}" install