archrelease: copy trunk to extra-x86_64
[arch-packages.git] / libksysguard / trunk / PKGBUILD
blobbecf417fbbf42086284ed4667c1cf9a5100764ee
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 # Contributor: Andrea Scarpino <andrea@archlinux.org>
5 pkgname=libksysguard
6 pkgver=5.27.5
7 _dirver=$(echo $pkgver | cut -d. -f1-3)
8 pkgrel=1
9 pkgdesc='Library to retrieve information on the current status of computer hardware'
10 arch=(x86_64)
11 url='https://kde.org/plasma-desktop/'
12 license=(LGPL)
13 depends=(libxres qt5-webengine knewstuff)
14 makedepends=(extra-cmake-modules kdoctools qt5-tools)
15 conflicts=('ksysguard<5.21.90')
16 groups=(plasma)
17 source=(https://download.kde.org/stable/plasma/$_dirver/$pkgname-$pkgver.tar.xz{,.sig})
18 install=libksysguard.install
19 sha256sums=('7e7eb53af05fefcfea6b38fed4947409370ad303247892e4719bc2a809e85e14'
20             'SKIP')
21 validpgpkeys=('E0A3EB202F8E57528E13E72FD7574483BB57B18D'  # Jonathan Esk-Riddell <jr@jriddell.org>
22               '0AAC775BB6437A8D9AF7A3ACFE0784117FBCE11D'  # Bhushan Shah <bshah@kde.org>
23               'D07BD8662C56CB291B316EB2F5675605C74E02CF'  # David Edmundson <davidedmundson@kde.org>
24               '1FA881591C26B276D7A5518EEAAF29B42A678C20') # Marco Martin <notmart@gmail.com>
26 build() {
27   cmake -B build -S $pkgname-$pkgver \
28     -DCMAKE_INSTALL_LIBEXECDIR=lib \
29     -DBUILD_TESTING=OFF
30   cmake --build build
33 package() {
34   DESTDIR="$pkgdir" cmake --install build