archrelease: copy trunk to extra-x86_64
[arch-packages.git] / libktorrent / trunk / PKGBUILD
blob7fe7a3332ae13c94b30ebc177c3165767a280293
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Contributor: Ronald van Haren <ronald.archlinux.org>
3 # Contributor: Andrea Scarpino <andrea@archlinux.org>
5 pkgname=libktorrent
6 pkgver=23.04.1
7 pkgrel=1
8 pkgdesc='A BitTorrent protocol implementation'
9 arch=(x86_64)
10 url='https://apps.kde.org/ktorrent/'
11 license=(GPL2)
12 depends=(kio qca-qt5)
13 makedepends=(extra-cmake-modules boost doxygen)
14 source=(https://download.kde.org/stable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz{,.sig})
15 sha256sums=('63cb152864392c6b2d8dc176459b35f80eb8c68c4b9aca3fc1a764d5374035ce'
16             'SKIP')
17 validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7  # Albert Astals Cid <aacid@kde.org>
18               F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87  # Christoph Feck <cfeck@kde.org>
19               D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heiko.becker@kde.org>
21 build() {
22   cmake -B build -S $pkgname-$pkgver
23   cmake --build build
26 package() {
27   DESTDIR="$pkgdir" cmake --install build