archrelease: copy trunk to extra-x86_64
[arch-packages.git] / libmypaint / trunk / PKGBUILD
blob9847ec81946f51a65f09d32a5a7807d33c827264
1 # Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
2 # Contributor: twa022 <twa022 at gmail dot com>
4 pkgname=libmypaint
5 pkgver=1.6.1
6 pkgrel=1
7 pkgdesc='Library for making brushstrokes which is used by MyPaint and other projects'
8 url='http://mypaint.org/'
9 arch=('x86_64')
10 license=('ISC')
11 depends=('glibc' 'json-c' 'gegl' 'glib2' 'json-glib' 'babl')
12 makedepends=('intltool' 'python' 'python-sphinx' 'python-breathe' 'gobject-introspection' 'doxygen')
13 source=(https://github.com/mypaint/libmypaint/archive/v${pkgver}/${pkgname}-${pkgver}.tar.gz
14         libmypaint-autoconf-2.7.patch::https://github.com/mypaint/libmypaint/commit/a6bac154db018e1f1cc4dbddc34f6c8422c891fb.patch)
15 sha512sums=('f759223e2e2da9fcc675bc2fa6324e2688ab36bdd979c0b3fad6737a6884e6095b6599c37960fd4897b9fd9063d5643fc2ab7e559438095c1872e019cd46d38b'
16             'a3ed4de701c24fa2fe1bdd50c0f2993f35c238e0145b514b2eee60cd35c4928f5aa552d761326ac9722da485a034421d1b3222c13d79e82812f78755a96158b4')
17 b2sums=('08e88b83391a237f89f8eb601421f822f74e2e02607ebe7e28c52b5bc6060b39102ded44ff530016bfd4fb4882006dbbeac71964b9962645e1b9068f8efe5f55'
18         '0086daed928fa300e5c64049ac1779cb77c74727ad0a7baebd6bd6bfc6326207d3a434b401f1b0ce10aeec00e103e493e273c346a05b0c6f5da76db9ccea6c16')
20 prepare() {
21   cd ${pkgname}-${pkgver}
22   patch -Np1 < ../libmypaint-autoconf-2.7.patch
23   ./autogen.sh
24   autoreconf -fiv
27 build() {
28   cd ${pkgname}-${pkgver}
29   ./configure \
30     --prefix=/usr \
31     --enable-gegl \
32     --enable-docs
33   make
36 check() {
37   cd ${pkgname}-${pkgver}
38   make check
41 package() {
42   cd ${pkgname}-${pkgver}
43   make DESTDIR="${pkgdir}" install
44   install -Dm 644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
45   install -Dm 644 COPYING -t "${pkgdir}/usr/share/licenses/${pkgname}"
48 # vim: ts=2 sw=2 et: