1 # Maintainer: AndyRTR <andyrtr@archlinux.org>
7 pkgdesc="a simple thesaurus"
9 url="https://github.com/hunspell/mythes"
11 depends=('glibc' 'perl')
12 makedepends=('hunspell')
14 source=(https://github.com/hunspell/mythes/releases/download/v${pkgver}/mythes-${pkgver}.tar.xz)
15 sha256sums=('19279f70707bbe5ffa619f2dc319f888cec0c4a8d339dc0a21330517bd6f521d')
18 cd "${pkgname/lib/}"-$pkgver
19 ./configure --prefix=/usr --disable-static
20 sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
25 cd "${pkgname/lib/}"-$pkgver
27 # run the example program:
28 ./example th_en_US_new.idx th_en_US_new.dat checkme.lst
29 # run the example program with stemming and morphological generation:
30 # e.g. to check mouse, mice, rodents, eats, eaten, ate, eating etc. words
31 ./example morph.idx morph.dat morph.lst morph.aff morph.dic
35 cd "${pkgname/lib/}"-$pkgver
36 make DESTDIR="$pkgdir" install
38 install -Dm644 "${srcdir}"/${pkgname/lib/}-$pkgver/COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING