archrelease: copy trunk to extra-x86_64
[arch-packages.git] / libmythes / trunk / PKGBUILD
blob400aa6ade0952e485e08c2455f2e3c8a8617bc6a
1 # Maintainer: AndyRTR <andyrtr@archlinux.org>
3 pkgname=libmythes
4 pkgver=1.2.5
5 pkgrel=1
6 epoch=1
7 pkgdesc="a simple thesaurus"
8 arch=('x86_64')
9 url="https://github.com/hunspell/mythes"
10 license=('custom')
11 depends=('glibc' 'perl')
12 makedepends=('hunspell')
13 provides=('mythes')
14 source=(https://github.com/hunspell/mythes/releases/download/v${pkgver}/mythes-${pkgver}.tar.xz)
15 sha256sums=('19279f70707bbe5ffa619f2dc319f888cec0c4a8d339dc0a21330517bd6f521d')
17 build() {
18   cd "${pkgname/lib/}"-$pkgver
19   ./configure --prefix=/usr --disable-static
20   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
21   make
24 check() {
25   cd "${pkgname/lib/}"-$pkgver
26   make check
27   # run the example program:
28   ./example th_en_US_new.idx th_en_US_new.dat checkme.lst
29   # run the example program with stemming and morphological generation:
30   # e.g. to check mouse, mice, rodents, eats, eaten, ate, eating etc. words
31   ./example morph.idx morph.dat morph.lst morph.aff morph.dic
34 package() {
35   cd "${pkgname/lib/}"-$pkgver
36   make DESTDIR="$pkgdir" install
37   # license
38   install -Dm644 "${srcdir}"/${pkgname/lib/}-$pkgver/COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING