archrelease: copy trunk to extra-x86_64
[arch-packages.git] / libogg / repos / extra-x86_64 / PKGBUILD
blob4405d7e2620a8116beb2a4d74986f03830e15d45
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: Tom Gundersen <teg@jklm.no>
3 # Contributor: John Proctor <jproctor@prium.net>
5 pkgname=libogg
6 pkgver=1.3.5
7 pkgrel=1
8 pkgdesc='Ogg bitstream and framing library'
9 arch=(x86_64)
10 url=https://www.xiph.org/ogg/
11 license=(BSD)
12 depends=(glibc)
13 makedepends=(
14   cmake
15   git
16   ninja
18 provides=(libogg.so)
19 source=(git+https://github.com/xiph/ogg.git?signed#tag=65b355cc20171010ecabf245e7b339aeab8ddbb9)
20 sha256sums=(SKIP)
21 validpgpkeys=(B7B00AEE1F960EEA0FED66FB9259A8F2D2D44C84) # Ralph Giles <giles@thaumas.net>
23 pkgver() {
24   cd ogg
25   git describe --tags | sed 's/^v//'
28 prepare() {
29   cd ogg
32 build() {
33   cmake -S ogg -B build -G Ninja \
34     -DCMAKE_INSTALL_PREFIX=/usr \
35     -DBUILD_SHARED_LIBS=ON
36   cmake --build build
39 package() {
40   DESTDIR="${pkgdir}" cmake --install build
41   install -Dm 644 ogg/COPYING -t "${pkgdir}"/usr/share/licenses/${pkgname}/
42   install -Dm 644 ogg/ogg.m4 -t "${pkgdir}"/usr/share/aclocal/
45 # vim: ts=2 sw=2 et: