1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: Tom Gundersen <teg@jklm.no>
3 # Contributor: John Proctor <jproctor@prium.net>
8 pkgdesc='Ogg bitstream and framing library'
10 url=https://www.xiph.org/ogg/
19 source=(git+https://github.com/xiph/ogg.git?signed#tag=65b355cc20171010ecabf245e7b339aeab8ddbb9)
21 validpgpkeys=(B7B00AEE1F960EEA0FED66FB9259A8F2D2D44C84) # Ralph Giles <giles@thaumas.net>
25 git describe --tags | sed 's/^v//'
33 cmake -S ogg -B build -G Ninja \
34 -DCMAKE_INSTALL_PREFIX=/usr \
35 -DBUILD_SHARED_LIBS=ON
40 DESTDIR="${pkgdir}" cmake --install build
41 install -Dm 644 ogg/COPYING -t "${pkgdir}"/usr/share/licenses/${pkgname}/
42 install -Dm 644 ogg/ogg.m4 -t "${pkgdir}"/usr/share/aclocal/