1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
4 pkgname=(libpanel libpanel-docs)
7 pkgdesc="Dock/panel library for GTK 4"
8 url="https://gitlab.gnome.org/GNOME/libpanel"
22 _commit=2757c49ed68507f38f14aca244eef5ec90ae00ee # tags/1.2.0^0
23 source=("git+https://gitlab.gnome.org/GNOME/libpanel.git#commit=$_commit")
28 git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
33 -D install-examples=true
36 arch-meson $pkgname build "${meson_options[@]}"
37 meson compile -C build
41 meson test -C build --print-errorlogs
45 provides=(libpanel-1.so)
47 meson install -C build --destdir "$pkgdir"
49 mkdir -p doc/usr/share
50 mv {"$pkgdir",doc}/usr/share/doc
53 package_libpanel-docs() {
54 pkgdesc+=" (documentation)"
60 # vim:set sw=2 sts=-1 et: