archrelease: copy trunk to extra-x86_64
[arch-packages.git] / libpanel / repos / extra-x86_64 / PKGBUILD
blob6a43b9c44166d402d38d61e1f4aaae3d8546a869
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgbase=libpanel
4 pkgname=(libpanel libpanel-docs)
5 pkgver=1.2.0
6 pkgrel=1
7 pkgdesc="Dock/panel library for GTK 4"
8 url="https://gitlab.gnome.org/GNOME/libpanel"
9 arch=(x86_64)
10 license=(LGPL)
11 depends=(
12   gtk4
13   libadwaita
15 makedepends=(
16   gi-docgen
17   git
18   gobject-introspection
19   meson
20   vala
22 _commit=2757c49ed68507f38f14aca244eef5ec90ae00ee  # tags/1.2.0^0
23 source=("git+https://gitlab.gnome.org/GNOME/libpanel.git#commit=$_commit")
24 b2sums=('SKIP')
26 pkgver() {
27   cd $pkgname
28   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
31 build() {
32   local meson_options=(
33     -D install-examples=true
34   )
36   arch-meson $pkgname build "${meson_options[@]}"
37   meson compile -C build
40 check() {
41   meson test -C build --print-errorlogs
44 package_libpanel() {
45   provides=(libpanel-1.so)
47   meson install -C build --destdir "$pkgdir"
49   mkdir -p doc/usr/share
50   mv {"$pkgdir",doc}/usr/share/doc
53 package_libpanel-docs() {
54   pkgdesc+=" (documentation)"
55   depends=()
57   mv doc/* "$pkgdir"
60 # vim:set sw=2 sts=-1 et: