archrelease: copy trunk to extra-x86_64
[arch-packages.git] / libreoffice-fresh / trunk / PKGBUILD
blobda589eb641390f092ca8cd04097d516b6b97d851
1 # Maintainer: AndyRTR <andyrtr@archlinux.org>
2 # Contributor: BartÅ‚omiej Piotrowski <bpiotrowski@archlinux.org>
4 # Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
5 # Note: These are for Arch Linux use ONLY. For your own distribution, please
6 # get your own set of keys. Feel free to contact foutrelis@archlinux.org for
7 # more information.
8 _google_default_client_id=413772536636.apps.googleusercontent.com
9 _google_default_client_secret=0ZChLK6AxeA3Isu96MkwqDR4
11 pkgbase=libreoffice-fresh
12 pkgname=('libreoffice-fresh-sdk' 'libreoffice-fresh')
13 _LOver=7.5.3.2
14 pkgver=7.5.3
15 pkgrel=2
16 arch=('x86_64')
17 license=('LGPL3')
18 url="https://www.libreoffice.org/"
19 makedepends=('curl>=7.20.0' 'hunspell>=1.2.8' 'python' 'libwpd>=0.9.2' 'libwps'
20         'neon>=0.28.6' 'pango' 'nspr' 'libjpeg' 'libxrandr' 'libgl' 'dbus-glib'
21         'libxslt' 'redland' 'hyphen' 'lpsolve' 'gcc-libs' 'sh' 'graphite' 'icu' 
22         'lcms2' 'poppler>=0.24.0' 'libvisio' 'libetonyek' 'libodfgen' 'libcdr'
23         'libmspub' 'harfbuzz-icu' 'nss' 'hicolor-icon-theme'
24         'desktop-file-utils' 'shared-mime-info' 'gst-plugins-base-libs'
25         'sane' 'perl-archive-zip' 'zip' 'unzip' 'unixodbc' 'ant'
26         'gperf' 'gtk3' 'gtk4' 'qt5-base' 'plasma-framework' 'qt6-base' 'cppunit' 'beanshell' 'clucene'
27         'junit' 'libmythes' 'libwpg'  'java-environment=11' 'postgresql-libs' 'mariadb-libs' 'libgl'
28         'bluez-libs' 'gdb' 'doxygen'  'libatomic_ops'  'mdds'
29         'ttf-liberation' 'ttf-dejavu' 'ttf-carlito' 'libxinerama' 'libpagemaker' 'glm'
30         'libabw' 'libmwaw' 'libe-book' 'coin-or-mp' 'liblangtag' 'liborcus' 
31         'libexttextcat' 'gobject-introspection' # 'libfbclient' 'libcmis' 
32         'libtommath' 'libzmf' 'xmlsec' 'rxvt-unicode' 'gpgme' 'libwebp'
33         'libepubgen' 'libfreehand' 'libqxp' 'libstaroffice'  'boost' 'libnumbertext'
34         'abseil-cpp' 'clang' 'zxing-cpp'
35         'libffi' 'box2d' 'git'
37 options=('!lto') # using --enable-lto (for parallel link-time optimization)
38 _mirror="https://download.documentfoundation.org/libreoffice/src/${pkgver}"
39 #_mirror="https://dev-builds.libreoffice.org/pre-releases/src"
40 _additional_source_url="https://dev-www.libreoffice.org/src"
41 _additional_source_url2="https://dev-www.libreoffice.org/extern"
42 source=(${_mirror}/libreoffice{,-help,-translations}-${_LOver}.tar.xz{,.asc}
43         ${_additional_source_url}/35c94d2df8893241173de1d16b6034c0-swingExSrc.zip
44         ${_additional_source_url}/798b2ffdc8bcfe7bca2cf92b62caf685-rhino1_5R5.zip # keep old bundled version, new system version ftbs
45         ${_additional_source_url}/a7983f859eafb2677d7ff386a023bc40-xsltml_2.1.2.zip
46         ${_additional_source_url}/0168229624cfac409e766913506961a8-ucpp-1.3.2.tar.gz
47         ${_additional_source_url}/language-subtag-registry-2021-03-05.tar.bz2
48         ${_additional_source_url}/17410483b5b5f267aa18b7e00b65e6e0-hsqldb_1_8_0.zip
49         ${_additional_source_url}/d8bd5eed178db6e2b18eeed243f85aa8-flute-1.1.6.zip
50         ${_additional_source_url}/ba2930200c9f019c2d93a8c88c651a0f-flow-engine-0.9.4.zip
51         ${_additional_source_url}/pdfium-5408.tar.bz2
52         ${_additional_source_url}/dtoa-20180411.tgz
53         ${_additional_source_url}/lxml-4.1.1.tgz
54         ${_additional_source_url}/Firebird-3.0.7.33374-0.tar.bz2
55         ${_additional_source_url}/skia-m103-b301ff025004c9cd82816c86c547588e6c24b466.tar.xz
56         ${_additional_source_url}/libcmis-0.5.2.tar.xz
57         ${_additional_source_url}/dragonbox-1.1.3.tar.gz
58         ${_additional_source_url2}/8249374c274932a21846fa7629c2aa9b-officeotron-0.7.4-master.jar  # for test suite
59         ${_additional_source_url2}/odfvalidator-1.2.0-incubating-SNAPSHOT-jar-with-dependencies-971c54fd38a968f5860014b44301872706f9e540.jar # for test suite
60         ${_additional_source_url2}/f543e6e2d7275557a839a164941c0a86e5f2c3f2a0042bfc434c88c6dde9e140-opens___.ttf
61         ${_additional_source_url2}/185d60944ea767075d27247c3162b3bc-unowinreg.dll
62         make-pyuno-work-with-system-wide-module-install.diff
63         623ea5c.diff
64         soffice-template.desktop.in 
65         libreoffice-fresh.sh libreoffice-fresh.csh)
66 noextract=(35c94d2df8893241173de1d16b6034c0-swingExSrc.zip
67            798b2ffdc8bcfe7bca2cf92b62caf685-rhino1_5R5.zip
68            a7983f859eafb2677d7ff386a023bc40-xsltml_2.1.2.zip
69            0168229624cfac409e766913506961a8-ucpp-1.3.2.tar.gz
70            language-subtag-registry-2021-03-05.tar.bz2
71            17410483b5b5f267aa18b7e00b65e6e0-hsqldb_1_8_0.zip
72            d8bd5eed178db6e2b18eeed243f85aa8-flute-1.1.6.zip
73            ba2930200c9f019c2d93a8c88c651a0f-flow-engine-0.9.4.zip
74            pdfium-5408.tar.bz2
75            dtoa-20180411.tgz
76            lxml-4.1.1.tgz
77            Firebird-3.0.7.33374-0.tar.bz2
78            skia-m103-b301ff025004c9cd82816c86c547588e6c24b466.tar.xz
79            libcmis-0.5.2.tar.xz
80            dragonbox-1.1.3.tar.gz
81            8249374c274932a21846fa7629c2aa9b-officeotron-0.7.4-master.jar  # for test suite
82            odfvalidator-1.2.0-incubating-SNAPSHOT-jar-with-dependencies-971c54fd38a968f5860014b44301872706f9e540.jar  # for test suite
83            f543e6e2d7275557a839a164941c0a86e5f2c3f2a0042bfc434c88c6dde9e140-opens___.ttf
84            185d60944ea767075d27247c3162b3bc-unowinreg.dll
86 validpgpkeys=('C2839ECAD9408FBE9531C3E9F434A1EFAFEEAEA3') # LibreOffice Build Team (CODE SIGNING KEY) <build@documentfoundation.org>
87 sha256sums=('14367aeed3a8ae01e17438679d93c4905ca7f9d2f2cb99e716ea297b8af2e048'
88             'SKIP'
89             'c9c4edf276c1c024550455b9c98762ab8bfdc1a10df417dd78e469aa8b8baad3'
90             'SKIP'
91             'aef14e7808c10a78bbb6723029ecafb1e6a693e376ac2260ec935d45c098064f'
92             'SKIP'
93             '64585ac36a81291a58269ec5347e7e3e2e8596dbacb9221015c208191333c6e1'
94             '1fb458d6aab06932693cc8a9b6e4e70944ee1ff052fa63606e3131df34e21753'
95             '75823776fb51a9c526af904f1503a7afaaab900fba83eda64f8a41073724c870'
96             '983941d31ee8d366085cadf28db75eb1f5cb03ba1e5853b98f12f7f51c63b776'
97             'ce80e8face06bf2ada363e0c159e3f990c4116fdae9232ca43e6369aa82bf16a'
98             'd30b13f4ba2e3b6a2d4f020c0dee0a9fb9fc6fbcc2d561f36b78da4bf3802370'
99             '1b5b24f7bc543c0362b667692f78db8bab4ed6dafc6172f104d0bd3757d8a133'
100             '233f66e8d25c5dd971716d4200203a612a407649686ef3b52075d04b4c9df0dd'
101             '7db59b1e91f2bc0ab4c5e19d1a4f881e6a47dbb0d3b7e980a7358225b12a0f35'
102             '0082d0684f7db6f62361b76c4b7faba19e0c7ce5cb8e36c4b65fea8281e711b4'
103             '940caef1ec7c78e0c34b0f6b94fe42d0f2022915ffc78643d28538a5cfd0f40e'
104             'acb85cedafa10ce106b1823fb236b1b3e5d942a5741e8f8435cc8ccfec0afe76'
105             'c094a6247e44104beaaa0d00c825beb6baf1a8e532dc22214747495317a65bd9'
106             'd7b18d9602190e10d437f8a964a32e983afd57e2db316a07d87477a79f5000a2'
107             '09d63b05e9c594ec423778ab59b7a5aa1d76fdd71d25c7048b0258c4ec9c3384'
108             'f2443f27561af52324eee03a1892d9f569adc8db9e7bca55614898bc2a13a770'
109             '984f2a479df79e27e7b01a5815ac53ae64e07746b882262d8a64566494515504'
110             'f543e6e2d7275557a839a164941c0a86e5f2c3f2a0042bfc434c88c6dde9e140'
111             'eafde646a7dbe46d20c291685b0beac2382174d78d66ee990e229a1bf6e6cec6'
112             'c463654a73ecfbc242ff109726fb4faecdbfb3d91affafe919b24bea65afb563'
113             '440c9af5f3d1213d8ed7177282380f25cbc981cabc8b590dcb777aaae84178e5'
114             'd0be8099cbee3c9dfda694a828149b881c345b204ab68826f317580aafb50879'
115             'b43ed267643fc5ced803dca010427b12b1f10db485173ccb19efb3395e60c82e'
116             '66f2cb5d2ff9909ee9633aea73d5306fc8c4ff358fa526f45d9994210d3e23ff')
118 prepare() {
120         cd libreoffice-$_LOver
122         # move external sources into place
123         mkdir "${srcdir}"/ext_sources && pushd "${srcdir}"/ext_sources
124         for source in "${noextract[@]}"; do
125                 ln -s "${srcdir}"/$source .
126         done
127         popd
128         
129         # unowinreg.dll must be a file not a symlink or the result will become a broken symlink
130         # /usr/share/libreoffice/sdk/classes/win/unowinreg.dll -> /build/libreoffice/src/185d60944ea767075d27247c3162b3bc-unowinreg.dll
131         rm "${srcdir}"/ext_sources/185d60944ea767075d27247c3162b3bc-unowinreg.dll
132         cp -f "${srcdir}"/185d60944ea767075d27247c3162b3bc-unowinreg.dll "${srcdir}"/ext_sources
134         # fix not upstreamable pyuno paths - FS#54250
135         patch -Np1 -i "${srcdir}"/make-pyuno-work-with-system-wide-module-install.diff
137         # fix build - https://gerrit.libreoffice.org/c/core/+/145421
138         patch -Np1 -i "${srcdir}"/623ea5c.diff
140         #use the CFLAGS but remove the LibO overridden ones
141         for i in $CFLAGS; do
142                 case "$i" in
143                         -O?|-pipe|-Wall|-g|-fexceptions) continue;;
144                 esac
145                 ARCH_FLAGS="$ARCH_FLAGS $i"
146         done
149 build() {
150         cd libreoffice-$_LOver
152         # strip -s from Makeflags in case you use it to shorten build logs
153         _MAKEFLAGS=${MAKEFLAGS/-s/}
155         # Build only minimal debug info to reduce size (~1.2GB -> ~225MB)
156         CFLAGS=${CFLAGS/-g /-g1 }
157         CXXFLAGS=${CXXFLAGS/-g /-g1 }
159         # http://site.icu-project.org/download/61#TOC-Migration-Issues
160         CPPFLAGS+=' -DU_USING_ICU_NAMESPACE=1'
162         # fix build with qt6 expecting libexec path
163         export qt6_libexec_dirs="/usr/lib/qt6"
165         ./autogen.sh --with-extra-buildid="${pkgver}-${pkgrel}" \
166                 --with-vendor="Arch Linux" \
167                 --enable-split-app-modules \
168                 --with-parallelism=${_MAKEFLAGS/-j/} \
169                 --with-external-tar="${srcdir}/ext_sources" \
170                 --disable-fetch-external \
171                 --enable-release-build \
172                 --prefix=/usr --exec-prefix=/usr --sysconfdir=/etc \
173                 --libdir=/usr/lib --mandir=/usr/share/man \
174                 --with-lang="" \
175                 --with-help=html \
176                 --disable-avahi \
177                 --enable-dbus \
178                 --enable-evolution2\
179                 --enable-gio\
180                 --enable-gtk3-kde5 \
181                 --enable-kf5 \
182                 --enable-qt5 \
183                 --enable-qt6 \
184                 --enable-gtk3 \
185                 --enable-gtk4 \
186                 --enable-introspection \
187                 --enable-lto \
188                 --enable-openssl \
189                 --enable-odk\
190                 --enable-python=system \
191                 --enable-scripting-beanshell \
192                 --enable-scripting-javascript \
193                 --disable-dconf \
194                 --disable-report-builder \
195                 --enable-ext-wiki-publisher \
196                 --enable-ext-nlpsolver \
197                 --without-fonts\
198                 --with-system-libcdr \
199                 --with-system-mdds\
200                 --without-myspell-dicts \
201                 --with-system-libvisio \
202                 --without-system-libcmis \
203                 --with-system-libmspub \
204                 --with-system-libexttextcat \
205                 --with-system-orcus \
206                 --with-system-liblangtag \
207                 --with-system-libodfgen \
208                 --with-system-libmwaw \
209                 --with-system-libetonyek \
210                 --with-system-libfreehand \
211                 --without-system-firebird \
212                 --with-system-zxing \
213                 --with-system-libtommath \
214                 --with-system-libatomic-ops \
215                 --with-system-libebook \
216                 --with-system-libabw \
217                 --with-system-coinmp \
218                 --with-system-dicts \
219                 --with-external-dict-dir=/usr/share/hunspell \
220                 --with-external-hyph-dir=/usr/share/hyphen \
221                 --with-external-thes-dir=/usr/share/mythes \
222                 --with-system-beanshell \
223                 --with-system-cppunit\
224                 --with-system-graphite\
225                 --with-system-glm \
226                 --with-system-libnumbertext \
227                 --with-system-libwpg \
228                 --with-system-libwps \
229                 --with-system-redland\
230                 --with-system-libzmf \
231                 --with-system-gpgmepp \
232                 --with-system-libstaroffice \
233                 --with-jdk-home="/usr/lib/jvm/default" \
234                 --with-ant-home="/usr/share/ant"\
235                 --with-system-boost\
236                 --with-system-icu \
237                 --with-system-cairo \
238                 --with-system-libs \
239                 --with-system-mythes \
240                 --with-system-headers \
241                 --without-system-hsqldb \
242                 --with-system-clucene \
243                 --without-system-dragonbox \
244                 --without-system-libfixmath \
245                 --with-gdrive-client-id=${_google_default_client_id} \
246                 --with-gdrive-client-secret=${_google_default_client_secret} \
247                 --disable-dependency-tracking
249         touch src.downloaded
250         make build
252         mkdir "${srcdir}"/fakeinstall
253         make DESTDIR="${srcdir}"/fakeinstall distro-pack-install
256 #check() {
257 #       cd "${srcdir}"/build
258 #       make check
261 package_libreoffice-fresh-sdk() {
262         pkgdesc="Software Development Kit for LibreOffice Fresh"
263         depends=('libreoffice-fresh' 'gcc-libs' 'sh' 'make' 'zip' 'gcc' 'java-environment')
264         provides=('libreoffice-sdk')
265         conflicts=('libreoffice-still-sdk')
267         for dir in $(grep -h ^%dir libreoffice-$_LOver/file-lists/sdk{,_doc}_list.txt); do
268                 install -dm755 "${pkgdir}"/${dir/\%dir/}
269         done
271         for file in $(grep -h -v ^%dir libreoffice-$_LOver/file-lists/sdk{,_doc}_list.txt); do
272                 dirname=$(dirname $file)
273                 [[ -d "${pkgdir}"/$dirname ]] || install -dm755 "${pkgdir}"/$dirname
274                 mv "${srcdir}"/fakeinstall/${file} "${pkgdir}"/$file
275         done
277         # fix environment path to keep compatibility with other java-environments
278         sed -i -e "s:\/usr\/lib\/jvm\/java-7-openjdk:\$J2SDKDIR:" \
279                 "${pkgdir}"/usr/lib/libreoffice/sdk/setsdkenv_unix.sh
281         # fix permissions
282         find "${pkgdir}"/usr/lib/libreoffice/sdk/examples -type f -exec chmod -x {} +
283         
284         # add LibreOfficeKit headers; FS#48066
285         install -dm755 "${pkgdir}"/usr/include/LibreOfficeKit
286         install -v -m644 "${srcdir}"/libreoffice-$_LOver/include/LibreOfficeKit/* "${pkgdir}"/usr/include/LibreOfficeKit
289 package_libreoffice-fresh() {
290         pkgdesc="LibreOffice branch which contains new features and program enhancements"
291         depends=('curl>=7.20.0' 'hunspell>=1.2.8' 'python' 'libwpd>=0.9.2' 'libwps'
292                 'neon>=0.28.6' 'pango' 'nspr' 'libjpeg' 'libxrandr' 'libgl'
293                 'libxslt' 'redland' 'hyphen' 'lpsolve' 'gcc-libs' 'sh' 'graphite' 'icu' 
294                 'lcms2' 'poppler>=0.24.0' 'libvisio' 'libetonyek' 'libodfgen' 'libcdr'
295                 'libmspub' 'harfbuzz-icu' 'nss' 'clucene' 'hicolor-icon-theme'
296                 'desktop-file-utils' 'shared-mime-info' 'libpagemaker'
297                 'libxinerama' 'libabw' 'libmwaw' 'libe-book' 'libcups'
298                 'liblangtag' 'libexttextcat' 'liborcus' 'libwebp' # 'libfbclient' 'libcmis'
299                 'libtommath' 'libzmf' 'libatomic_ops' 'xmlsec' 'libnumbertext' 'gpgme' 
300                 'libfreehand' 'libstaroffice' 'libepubgen' 'libqxp' 'libepoxy' 'box2d'
301                 'zxing-cpp'
302                 'xdg-utils')
303         optdepends=('java-runtime:     adds java support'
304                 'java-environment: required by extension-wiki-publisher and extension-nlpsolver'
305                 'pstoedit:         translates PostScript and PDF graphics into other vector formats'
306                 'libmythes:        for use in thesaurus'
307                 'beanshell:       interactive java -- good for prototyping/macros'
308                 'libwpg:           library for importing and converting WordPerfect Graphics format'
309                 'sane:             for scanner access'
310                 'unixodbc:         adds ODBC database support'
311                 'gst-plugins-base-libs: for multimedia content, e.g. in Impress'
312                 'libpaper:         takes care of papersize'
313                 'postgresql-libs:  for postgresql-connector'
314                 'mariadb-libs:     for mysql-connector'
315                 'coin-or-mp:       required by the Calc solver'
316                 'gtk3:             for GTK3 integration'
317                 'gtk4:             for GTK4 integration (experimental)'
318                 'kio:              for KF5 KDE desktop integration'
319                 'qt6-base:         for QT6 desktop integration')
320         backup=(etc/libreoffice/sofficerc
321                 etc/libreoffice/bootstraprc
322                 etc/libreoffice/psprint.conf
323                 etc/profile.d/libreoffice-fresh.sh
324                 etc/profile.d/libreoffice-fresh.csh)
325         provides=('libreoffice' 'libreoffice-en-US')
326         conflicts=('libreoffice-still')
328         mv fakeinstall/* "${pkgdir}"/
330         # put configuration files into place
331         install -dm755 "${pkgdir}"/etc/libreoffice
332         install -m644 "${pkgdir}"/usr/lib/libreoffice/program/{bootstraprc,sofficerc} \
333                 "${pkgdir}"/etc/libreoffice/
334         install -m644 "${pkgdir}"/usr/lib/libreoffice/share/psprint/psprint.conf \
335                 "${pkgdir}"/etc/libreoffice/
337         # install dummy links to make them found by LibO
338         cd "${pkgdir}"/usr/lib/libreoffice/program/
339         ln -vsf /etc/libreoffice/{bootstraprc,sofficerc} .
340         cd "${pkgdir}"/usr/lib/libreoffice/share/psprint/
341         ln -vsf /etc/libreoffice/psprint.conf .
343         # allow to preset desired VLC
344         install -dm755 "${pkgdir}"/etc/profile.d
345         install -m644 "${srcdir}"/libreoffice-fresh.{sh,csh} "${pkgdir}"/etc/profile.d/
347         # make pyuno find its modules
348         local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
350         install -dm755 "${pkgdir}"/$site_packages
351         ln -svf /usr/lib/libreoffice/program/uno.py \
352                 "${pkgdir}"/$site_packages/uno.py
353         ln -svf /usr/lib/libreoffice/program/unohelper.py \
354                 "${pkgdir}"/$site_packages/unohelper.py
355                 
356         # add a symlink required for gnome-documents; FS#51887
357         # https://lists.freedesktop.org/archives/libreoffice/2016-March/073787.html
358         ln -svf /usr/lib/libreoffice/program/liblibreofficekitgtk.so \
359                 "${pkgdir}"/usr/lib/liblibreofficekitgtk.so  
361         # cleanup
362         rm -rf "${pkgdir}"/usr/share/libreoffice/sdk
364         # add application descriptions
365         install -dm755 "${pkgdir}"/usr/share/metainfo
366         install -v -m644 "${srcdir}"/libreoffice-$_LOver/sysui/desktop/appstream-appdata/*.xml \
367                 "${pkgdir}"/usr/share/metainfo
369         # add kde filemanager templates; FS#61662 - file taken from Debian
370         install -dm755 "${pkgdir}"/usr/share/templates/.source
371         install -v -m644 "${srcdir}"/libreoffice-$_LOver/extras/source/shellnew/soffice.* \
372                 "${pkgdir}"/usr/share/templates/.source
374         cat "${srcdir}"/soffice-template.desktop.in \
375                 | sed -e "s/@APP@/Writer/" \
376                 | sed -e "s/@EXT@/odt/" \
377                 | sed -e "s/@TYPE@/text/" \
378                 > "${pkgdir}"/usr/share/templates/soffice.odt.desktop
379         cat "${srcdir}"/soffice-template.desktop.in \
380                 | sed -e "s/@APP@/Calc/" \
381                 | sed -e "s/@EXT@/ods/" \
382                 | sed -e "s/@TYPE@/spreadsheet/" \
383                 > "${pkgdir}"/usr/share/templates/soffice.ods.desktop
384         cat "${srcdir}"/soffice-template.desktop.in \
385                 | sed -e "s/@APP@/Impress/" \
386                 | sed -e "s/@EXT@/odp/" \
387                 | sed -e "s/@TYPE@/presentation/" \
388                 > "${pkgdir}"/usr/share/templates/soffice.odp.desktop
389         cat "${srcdir}"/soffice-template.desktop.in \
390                 | sed -e "s/@APP@/Draw/" \
391                 | sed -e "s/@EXT@/odg/" \
392                 | sed -e "s/@TYPE@/drawing/" \
393                 > "${pkgdir}"/usr/share/templates/soffice.odg.desktop
395         # make all i18n lang packages with help section ('1') available to
396         # fix "F1" not opening translated offline help opening in browser
397         # see also /usr/lib/libreoffice/help/en-US/langnames.js
398         echo "var languagesSet = new Set(['en-US','am','ar','ast','bg','bn',\
399         'bn-IN','bo','bs','ca','ca-valencia','cs','da','de','dz','el',\
400         'en-GB','en-ZA','eo','es','et','eu','fi','fr','gl','gu','he',\
401         'hi','hr','hu','id','is','it','ja','ka','km','ko','lo','lt','lv',\
402         'mk','nb','ne','nl','nn','om','pl','pt','pt-BR','ro','ru','si',\
403         'sid','sk','sl','sq','sv','ta','tg','tr','ug','uk','vi','zh-CN','zh-TW'])" \
404                 > "${pkgdir}"/usr/lib/libreoffice/help/languages.js