1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
4 pkgname=(librest librest-docs librest-demos)
7 pkgdesc="Library for accessing RESTful web services"
8 url="https://gitlab.gnome.org/GNOME/librest"
11 depends=(glib2 libxml2 libsoup3 json-glib)
12 makedepends=(gobject-introspection git meson gi-docgen vala libadwaita
14 _commit=aa9e968e381ede159414c6338da24d61ad0b5d8b # tags/0.9.1^0
15 source=("git+https://gitlab.gnome.org/GNOME/librest.git#commit=$_commit"
18 'a5e54797a758b67c7f9aa6e90cd7b6435dfa1f7abc86b9b88c0c98e78724b15308ca8af4ccb138d1d01948e54ed9bf930ee37a7d253e6c979846f93f92fef2c2')
22 git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
28 # https://bugs.archlinux.org/task/76560
29 # https://gitlab.gnome.org/GNOME/librest/-/merge_requests/30
30 git apply -3 ../30.patch
34 arch-meson librest build -D vapi=true
35 meson compile -C build
39 meson test -C build --print-errorlogs
43 local p="$1" f d; shift
45 d="$srcdir/$p/${f#$pkgdir/}"
46 mkdir -p "$(dirname "$d")"
48 rmdir -p --ignore-fail-on-non-empty "$(dirname "$f")"
53 depends+=(libg{lib,object,io}-2.0.so libxml2.so libsoup-3.0.so
55 provides+=(librest{,-extras}-1.0.so)
57 meson install -C build --destdir "$pkgdir"
61 _pick docs usr/share/doc
63 _pick demo usr/bin/librest-demo
64 _pick demo usr/share/applications/org.gnome.RestDemo.desktop
67 package_librest-docs() {
68 pkgdesc+=" (documentation)"
73 package_librest-demos() {
74 pkgdesc+=" (demo applications)"
75 depends=(librest libadwaita gtksourceview5)
79 # vim:set sw=2 sts=-1 et: