archrelease: copy trunk to extra-x86_64
[arch-packages.git] / libsidplay / trunk / PKGBUILD
blobda03a5d518ec2d4d4f457ea709ecf1084395e064
1 # Maintainer: Jan de Groot <jgc@archlinux.org>
2 # Contributor: Kritoke <kritoke@gamebox.net>
4 pkgname=libsidplay
5 pkgver=1.36.59
6 pkgrel=10
7 pkgdesc="A library for playing SID music files."
8 arch=('x86_64')
9 url="https://critical.ch/distfiles/"
10 license=('GPL')
11 depends=('gcc-libs')
12 source=(https://critical.ch/distfiles/${pkgname}-${pkgver}.tgz
13         libsidplay-1.36.59-gcc43.patch
14         g++-6_build.patch)
15 sha256sums=('3da9b38d4eb5bf9e936b9604ba92da0594ef38047d50cf806a8e11c400008024'
16             '68476bfee9a378b045c81eb0f6d9aee7341610fe6b22047d67ce859a7a3b5053'
17             '6612b8c684bfd80d88431d3aa7f5a3fc911528f25f67ab530f78a7592cc11e23')
19 prepare() {
20   cd ${pkgname}-${pkgver}
21   patch -Np1 -i ../libsidplay-1.36.59-gcc43.patch
22   patch -Np1 -i ../g++-6_build.patch
25 build() {
26   cd ${pkgname}-${pkgver}
27   ./configure --prefix=/usr
28   make
31 package() {
32   cd ${pkgname}-${pkgver}
33   make DESTDIR="${pkgdir}" install