archrelease: copy trunk to extra-x86_64
[arch-packages.git] / libsignon-glib / trunk / PKGBUILD
blobbf4321f87bbb4a63b909f94242a8bf07d8842b28
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Contributor: Maxime Gauduin <alucryd@archlinux.org>
3 # Contributor: Balló György <ballogyor+arch@gmail.com>
5 pkgname=libsignon-glib
6 pkgver=2.1
7 pkgrel=6
8 pkgdesc='GLib-based client library for applications handling account authentication through the Online Accounts Single Sign-On service'
9 arch=(x86_64)
10 url='https://gitlab.com/accounts-sso/libsignon-glib'
11 license=(LGPL2.1)
12 depends=(signond)
13 makedepends=(python-gobject gtk-doc gobject-introspection vala meson git)
14 source=("git+https://gitlab.com/accounts-sso/${pkgname}#tag=VERSION_$pkgver")
15 sha256sums=('SKIP')
17 prepare() {
18   mkdir -p build
20   cd $pkgname
21   git submodule init
22   git submodule update
25 build() {
26   cd build
27   arch-meson ../$pkgname -Dtests=false
28   ninja
31 package() {
32   cd build
33   DESTDIR="$pkgdir" ninja install