archrelease: copy trunk to extra-x86_64
[arch-packages.git] / libsoxr / repos / extra-x86_64 / PKGBUILD
blob2d981c1c7fa484d4060234686ba9e5005209674d
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: Anatol Pomozov
3 # Contributor: JSpaces <jspace@unseen.is>
4 # Contributor: Triode <triode1@btinternet.com>
6 pkgname=libsoxr
7 pkgver=0.1.3
8 pkgrel=3
9 pkgdesc='The SoX Resampler library that aims to give fast and high quality results for any constant resampling ratio'
10 arch=(x86_64)
11 url=https://sourceforge.net/p/soxr/wiki/Home/
12 license=(GPL)
13 depends=(gcc-libs)
14 makedepends=(
15   cmake
16   ninja
18 source=(https://downloads.sourceforge.net/project/soxr/soxr-$pkgver-Source.tar.xz)
19 b2sums=('5b7078f71404b9ef83917dcabc0c99cf17fd625d3e033d1b934382a7b60e55e359931a6ab53f8adaf955c0d811d6cbf231cd6a226549560b3506a3867e845607')
21 build() {
22   cmake -S soxr-${pkgver}-Source -B build -G Ninja \
23     -DCMAKE_BUILD_TYPE=None \
24     -DCMAKE_INSTALL_PREFIX=/usr \
25     -DBUILD_EXAMPLES=OFF \
26     -DBUILD_SHARED_LIBS=ON \
27     -DWITH_AVFFT=ON \
28     -DWITH_LSR_BINDINGS=ON \
29     -DWITH_OPENMP=ON \
30     -DWITH_PFFFT=ON
31     cmake --build build
34 check() {
35   ctest --test-dir build
38 package() {
39   DESTDIR="${pkgdir}" cmake --install build
40   rm -rf "${pkgdir}"/usr/share/doc
41   install -Dm 644 soxr-${pkgver}-Source/LICENCE -t "${pkgdir}"/usr/share/licenses/libsoxr/
44 # vim: ts=2 sw=2 et: